Shapeoko XL Loading Initial Sequence


(Charles) #1

I am new to CNC and have just finished assembling my XL and going through the instructions for Carbide Motion v4 I opened the log, selected XL and the lines scrolled up the screen but mine were not commands followed by $.

Not sure what is wrong. Anyone experience this?


(mikep) #2

You’re seeing lots of internal stuff to CM. You haven’t connected to the cutter yet.

What are you trying to do that’s not working?


(Charles) #3

I am having trouble getting the initial sequence. I have followed the instructions for homing and when I send the config and look at it in the log I don’t get the sequence with the $.

I get the junk I attached. They suggested re-imaging and sent me a file to do that and I did. It said it was successful. They also sent a file to get the config and when I ran that it was no different


(mikep) #4

That’s not actually looking wrong to me. It’s also doesn’t look like it’s connected. Did you connect to the machine?

Close the log.

Connect to the cutter. Does it home?


(Charles) #5

The machine was connected. The top line reflecting NONCONNECTED showed up after shutting it down.
The code I got looks nothing like the sample code they sent me.


(mikep) #6

You’re not telling me what isn’t actually working, you’re digging straight into details that aren’t necessarily the bit you need.

If the machine connects, and you’ve done the “shapeoko settings” part, restart CM, connect to the machine again…when you go to the jog screen, can you move the carriage with the jog buttons?


(Charles) #7

I have not been able to successfully run the Enable Homing in Carbide Motion. When I try to send the configuration I do not get the list of commands with the $ sign. That is what you are calling the Shapeoko settings rtight?


(mikep) #8

Don’t worry about the settings for a moment, there are other ways to deal with that.

restart CM, connect to the machine…when you go to the jog screen, can you move the carriage with the jog buttons?

Does it move the wrong direction with any of them? Does moving Y make a horrible noise?


(Charles) #9

let me go out to the garage and see


(Charles) #10

Launch CM and connect the machine. When I click click jog it automatically goes into homing and the spindle travels up the z axis and hits the limit switch but doesn’t stop.


(Charles) #11

When support had me re-image I had to hold the z limit switch and it worked so I think the switch is good just not getting the commands.


(William Adams) #12

To troubleshoot the homing switches please see: https://docs.carbide3d.com/software-faq/home-switch-troubleshooting/


(Charles) #13

Been there andf done that. Walked through it with the supports folks.


(Charles) #14

They keep saying I have a bad board.


(mikep) #15

If they keep saying it, it’s likely the case.

You shouldn’t need to “turn on limit switches” if this is a new board - if it has GRBL 1.1, -and- you’re using CM4, they’re required and don’t need to be “turned on.” If you’re trying to turn them on, then that sounds like you’re either using GRBL .9, and CM3, or you’re mixing CM3 with GRBL 1.1, which doesn’t work right.

Your problem has nothing to do with sending settings. The machine is homing (which it wouldn’t do if it didn’t have settings, and didn’t have the limit switch settings).

Regarding the switch - If the switch or cabling wasn’t working, you wouldn’t have been able to flash the board by holding the switch. The switch and its cable are at least connected properly. The bit that is confusing us is that it’s -acting- exactly like it would if the Z switch wasn’t connected properly…which doesn’t make sense if you were actually able to program the board.

I suspect what support was trying to do was get the list of current settings from your board. To do that, connect to the machine, open the log, then open the MDI page, and type $$ and return on the input line. then scroll back in the log and you should see a block of stuff that looks like “$100=40” and so forth.

If you can connect to the board (you can), and you aren’t getting output, there’s something really fishy going on - to connect requires the board to be able to send data. So the board can…well…send data, there’s no physical reason I can see why that would be the case then…stop.

Likewise, the switches are connected correctly, or you wouldn’t have been able to program the board…or…you weren’t actually able to program the board, and just can’t tell.


(Charles) #16

Thanks for keeping at it Mikep.
I apologize for not knowing more but like I said I am completely new to CNC.

You said that
“The machine is homing (which it wouldn’t do if it didn’t have settings, and didn’t have the limit switch settings).”
What exactly is telling you that it is homing.


(William Adams) #17

Let’s review:

  • XLs have always had homing switches
  • depending on when it was sold, it might have Grbl 0.9 or 1.1 flashed

If you have Grbl 0.9 you need to use Carbide Motion 3 and set the settings per: https://docs.carbide3d.com/software-faq/shapeoko-3-default-grbl-settings/ and https://docs.carbide3d.com/shapeoko-faq/shapeoko-enable-homing/

If you have Grbl 1.1 you need to use Carbide Motion 4 and set the settings per: https://docs.carbide3d.com/support/carbideupdater/#carbide-motion-v4

The basics of machine functionality are discussed at: https://wiki.shapeoko.com/index.php/SO3_Function_Test including troubleshooting.

If you break it down step-by-step to:

  • what you did
  • what you expected
  • what actually happened

we should be able to help you sort this out.


(Charles) #18

What is the easiest way to determine if I have 0.9 or 1.1


(William Adams) #19

Use Carbide Motion 4 — it will put up an error message if you’re using 0.9 since it only works with 1.1.


(Charles) #20

Okay. We can strike that off the list.
I am using CM 4 and it is communicating, at some level with the XL so I think I am good as far as the version of CM and 1.1.