Shapeoko XXL , Carbide motion do not stop the spindle for me to install the tool


(Alain St-Laurent) #21

Where is the “minimize tool changes” box in Carbide motion or in Fusion 360, I found “Reorder to minimize tool changes” and it is in Fusion 360 in the post-process menu when you create the nc file, I can try that and check my code after. But since I create file using only one tool I dont know if this will do anything, but I will try it, thanks


(Alain St-Laurent) #22

I just did the test on post-process without the selection “Reorder to mini…” and another with checking the box. in both cases in give the same code.

M9 ( M09:Mist Coolant Device Off )
T24 M6 ( T:Tool Number:24 M06:Tool change )
(24)
S17000 M3 ( S:Spindle Speed:17000 M03:Spindle On )
G54 ( G54:Zero offset #1 )

Interesting


(Neil Ferreri) #23

Remove the M6 from your gcode if you don’t actually need a tool change command. You can modify the Post processor to ignore it or set it as a user option.


(mikep) #24

2 things then

  1. Select one toolpath in the ui, not the whole set of them (for the purposes of getting this sorted out)
  2. select the “minimize tool changes” box

You should get a .nc file with NO “T” commands in it.

If you don’t, try this post:

C3D-SO3-DEWALT.cps.zip (5.5 KB)


(Alain St-Laurent) #25

Many thanks, I will be give it a try , I will let you know the result. Could take a day or two before I get the chance to do this.