Shapeoko xxl home switch

just finished putting together a new xxl and went to initialize machine but it fails and keeps running into side checked all swithes the red lights turn on and also the blue ones in the box. says cant find limit switch even the the switch red light turns on

Please see:

If that doesn’t help, let us know at and we’ll do our best to get this sorted out with you.

tried that and machine still not working just runs into sde and a grbl error homing switch not found pops up.

Please contact us at

There is a basic page on troubleshooting the homing switches at:

There is also a Carbide 3D Answer video:

For the new inductive homing switches: Troubleshooting: and Adjusting:

found on forum that another guy switched x znd z 4pin connectors on board so tried and now it works fine

Yes, if you start out with the Z and the X axis connectors miswired then correcting that will allow things to work.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.