SO3: Next chapter on the loss comm with Grbl board and project stops

(Valentin Parks) #1

I have posted on this before. I was still having grbl board issues even with the new board.
I read that slowing the router speed helped --> It did help a lot.

But I did see what I think the the root of the problem. You can see in the photo the router contact arcs. Mostly they are small but can get quite big at the highest speeds and under cutting load.

I first removed the 2 wire cable and installed a grounded power cable so the case is grounded. There is a posting somewhere with good pictures on how to do this.

Then I bought this…

and created a sort of Faraday Cage around the plastic router head & secured with a hose clamp.

Now I am ready to start some max speed testing again.

Does anyone know what RPM the max setting gives?

Is there any one else that think this makes sense?

0 Likes

GRBL might be freezing?
(William Adams) #2

At http://www.shapeoko.com/wiki/index.php/Spindle_Options#100_to_999_Watts

There’s a table of speeds:

1: 15820
2: 16960
3: 18950
4: 21280
5: 24270
6: 27080

Copied from: http://www.shapeoko.com/forum/viewtopic.php?f=8&t=3918&p=37978#p37978

I found that putting metallic tape on the top and bottom of the end plates I added to my electronics shroud seemed to help.

0 Likes

(Tim Foreman) #3

Brushed motors always arc at high speed. Look inside your cordless drill sometime when you pull the trigger.

According to the DeWalt specs, max is 27K RPM, but according to my SuperPID max is 30K RPM. I don’t know if the SuperPID is over-driving it somehow.

The cage is an interesting idea, but the holes in the mesh have to be the right size to block the right frequencies.

0 Likes

#4

Tim is right. Don’t despair if your copper screen fails, those are awfully big holes. Remember too that the holes you are covering are not the only place your EM noise will be squirting out of.

It can be a b*tch to make all those energetic little motor turning electrons play quietly with each other so they don’t bother the other electrons who are busy thinking in your computer.

I may just opt for a steam powered spindle and avoid the whole issue. :smile_cat:

1 Like

(Valentin Parks) #5

Will - thanks, just what I was looking for. Do you have a picture of your tape solution?

Hmmm, I realize the hole size is major design factor. How effective will depend on the wavelength or frequency of what’s coming out of the motor. That I don’t know, it’s probably over a spectrum for frequencies. However, the hole size is very comparable if not smaller than to what I see on computer cases.

0 Likes

#6

Im having problems with disconnects again as well. The problem started coming back in correlation with my dewalt getting much noisier during cutting. I suspect a combination of damaged brushes and rough bearings (putting strain on motor under load) is causing it to be electrically more noisy and so my disconnects are back!

do you think the latest iteration of the motion controller will help with this? waiting on a response from carbide 3d support.

0 Likes

(Valentin Parks) #7

I have 3 suggestions:

  1. If you haven’t done so already, change to a 3 wire grounded cord.
  2. The new board may help, but I personally didn’t see much difference. But it certainly does no harm. I just don’t like the huge capacitor hanging out, looks like an afterthought, which it is…
  3. Don’t turn the router on/off at the router, unplug it.

I am also leery of the vacuum cleaner I use. The hose builds up a huge static charge. I think I should ground strap it some how.
It is better to post a new topic to get an instant result from Will. So far I have only waited minutes for the “First Responder”.

0 Likes

(William Adams) #8

I believe that we have every suggestion on the USB disconnection problem here: http://www.shapeoko.com/wiki/index.php/Electronics#Recommendations

If anyone has any additional ideas, I’d be glad of them.

Not wild about yanking the plug on the router from a safety / wear standpoint — some people have had good luck w/ plugging it into a power strip and powering it on / off there. I use a router control unit from Harbor Freight, ignoring the speed control aspect.

0 Likes

(Tim Foreman) #9

While I have grounded the body of my DeWalt, I can’t see how changing the cord and grounding the body really does much. Other than giving a static charge somewhere to go when you touch the router body I can’t see any reason it should really help. All the electrical noise is generated by the brushes which are in the plastic housing and thus not shielded by the body.

You also don’t need to run a whole new cord to ground the router body. I ran a ground strap from the router to the mounting plate, then from the mounting plate to the carriage plate, then from the carriage plate to the end of the X rail, then to the end of the Y rail and then to the case on the power supply which is earth grounded. All the components of my machine are earth grounded and at the same potential.

I do occasionally still get disconnects when I touch the vacuum hose and the machine - I should probably add a ground wire to that - and recently I removed a fleece jacket and then touched a metal part of my laptop - zap, disconnected. :slight_smile:

Before I had my SuperPID I would turn the speed down on the router before turning it off - that seemed to help. I have not had a router power related disconnect since adding the SuperPID.

1 Like

#10

I’m thinking of getting a 1.5KW VFD spindle to replace the dewalt, what are the brushes like in these? The entire casing is metal so this should help with any EM emission right? The wire connecting it to the inverter will have braided shielding acting as the earth wire as well which should cut out any em from the cable.

0 Likes

(Valentin Parks) #11

@Tim,
Yeah, you may be right. Many have said “ground every fricken thing”. I did it for good measure, but the problem, like you say, is the router top housing being RFI transparent. For my Faraday cage idea, I had to have the router grounded.

One of my next projects is to make a Power/Control box to mount on the side of my cabinet. I plan to turn the router on/off from there as well as do some speed control. Can you share what your SuperPID looks like?

I keep hearing that people lose the comm. when they turn the router off.

This is a work in progress, not near finished…still playing around with concepts.

I am thinking about added this:

0 Likes

(Tim Foreman) #12

This is the SuperPID: http://www.vhipe.com/product-private/SuperPID-Home.htm

The advantage the SuperPID has is that you add a sensor (tach) to the router and the SuperPID ensures the speed stays constant by varying the power it feeds to the router. The other advantage is that the Grbl controller can turn the router on and off and set the speed using GCode. It’s pretty cool to hit the “Start” button and have the router turn on as it moves to the start of the program. Then at the end it turns off. I plan on add a controller that will turn the vacuum on and off with the router too. :slight_smile: The main drawback to the SuperPID is that it’s a bit expensive.

If you use that variable speed control that you show I’m pretty sure you will have to disable the built in one. It also has no feedback so the router will slow down when the bit hits the material.

0 Likes

(Mark Bellon) #13

+1 SuperPID. I mentioned in several postings as much as 6 months ago.

One does need to do some rewiring of their router so not for the faint of heart. That said, they provide pictures and instruction for each router so it isn’t too bad. I had SuperPID on a router for a CNC machine I had some time ago - worked great.

One of the major SO3 challenges I have in helping people is that I don’t know the RPMs. It might as well be “warp 6” or “ludicrous speed”. With SuperPID, one will know the RPM very accurately.

mark

2 Likes