SO3: Parts are aren't coming out the right dimensions

ive just built my shapeoko 3. i ran the “hello world” test code that they sent in an email, and that came out totally fine. now i’m trying to have it cut my own parts but they keep coming out much too small, although the geometry is correct. ive tried loading a .stl file into meshcam and it reads it as the correct size but when i export and run the g-code it comes out the wrong size. ive tried both the inch and mm shapeoko post processors, the problem is consistent, the part always comes out to the same dimensions no matter what i try. i’ve also tried making the same 2" square in carbide create and it too comes out to the same reduced size as the meshcam tests. i’m new to CNC and don’t know what to try next, im totally at a loss here.

any thoughts are appreciated!

Have you set your tool diameter correctly? Check what tool is on your machine and compare it to your machining parameters.

Calibrated for belt stretch?

Have you taken runout into account?