SO3: XXL Y Axis problems

I just purchased and assembled the Shapeoko 3 xxl Cnc and ran into a snag. Everything went together pretty good however I cant get the y2 stepper motor to work. I switched the motors around and it looks like the motor is fine. I checked the wiring connections and they are good as well. I verified this by swapping the connections at the board. It looks like the y2 connection on the board is not powering up the motor and cant find a fix for this. I would like to get machine operational so any assistance would be appreciated. Note the machine will still jog and home without the motor working however that’s about the extent of what I can do.


It sound like a bad board, contact and let them know what you’ve done.

Sounds like a bad Y driver on the board.
Email support @ carbide3d
Stranger Things have happened.

I have the same problem with my board. Did you ever find a solution?

Please put in an e-mail to — apparently there must have been a batch of bad stepper drivers — if you have a bad board, it should be replaced.

If that’s not an option for some reason, I suppose one could set up a drive shaft: — but I don’t believe anyone has yet done that for an SO3.

Had a bad board, they sent a replacement and it works fine now.

1 Like

I’m going to email support as requested above, but I just experienced a very similar issue. Maybe it can help someone else.

I finished setting up my XXL and was prepping to run hello world. In Carbide Motion, I was learning how to move things around using the onscreen arrows. X and Z axis worked as expected, but Y1 & Y2 are somehow reversed. When I click Y+, one Y drive moves forward and the other Y drive moves backward. And clicking Y- reverses everything, but each side still moves in opposite directions. This caused the gantry to bind up and jump. So instead of one motor not working as @cwbeaux experienced, mine both “work”, but they can’t seem to agree on which direction to go :frowning2:

Troubleshooting: I swapped connections for Y1 and Y2 on the board. As expected this did not fix anything. The motors still moved in opposite directions, but the whole thing was reversed.

Is this happening because I have something else swapped? Is it possibly a bad board as well? Thanks.

You can try inverting the axis in Carbide Motion under MDI. It solved my z axis reversal

Sounds as if the motor wires are crossed for one motor.

Use a tool to pop out two adjacent wires on one side or the other of the connector and swap them

If need be, invert the Y-axis bit: (add or subtract two to the value for $3). See

To change a setting:

  • launch Carbide Motion and connect
  • tap M to get to the MDI window
  • type $3=2 and click Send (assuming that $3 == 0 previously)

Are the wire colors consistent on both the Y motor connectors?
I hope Wills suggestion to swap the wires got you sorted out. Heres a picture for moral support.
If you need help still post a photo of your board.


Success! Thank you @WillAdams - It was in fact 2 switched wires inside the wire harness for the right Y axis. So glad that’s all it was.

@ApolloCrowe my wires on the circuit board end were identical to your photo. But at the other end of the wire harness going to the right Y axis, the green and white wires were backwards compared to the rest. I was able to easily switch the pins. I tested it again and it worked correctly immediately. I even ran my Hello World job. Here’s a pic. Took a video too but will have to edit it some and maybe post it later.

@Murdocjx - Thanks for the MDI suggestion. Sounds like that would have worked too. While i was reading up on the MDI stuff I saw the reply from Will. Thankfully that was the issue and it was a quick fix. Glad your issue got fixed as well.

I appreciate the help and such quick replies on a Friday night. Really awesome! My XXL is alive.