Software will not open when downloaded

I tried to download software but it would not open

Mac or Windows?

What error message are you getting?

Are the files completely downloaded?

Just tested with and got a 31.9MB (33,455,120 byte) file

File will download complety then when I try to open it deletes (windows7) also I have tried to download it in Crome and Internet explore with the same results I have Java ver. 8 on my laptop

AM I missing something…WHAT software, Carbide Motion, Carbide Create, MeshCam, and what version…

carbide motion I was trying to get stared . I have purchased a Shapeoko 3 and am putting it together and was needing what ever software to get stared with. I am new to cnc and will be learnig.

Awesome, and welcome to the club.

Carbide Motion. Right click on the file and Run as Administrator to install it. (this should work)

IF you get an error, please write it down, and take a picture of it so we can go from there.

It’s very important to allow up to help you and can only do so if we know (clearly) what the problem is.


this a screen shoot

Okay, that’s probably a Windows permissions or signed-binary error of some sort.

My suggestion would be to try downloading using an Admin account into a folder which is allowed to have binaries in it.

If that doesn’t work, please contact and someone who understands this stuff will work with you to puzzle it out.

1 Like

I downlaoded carbidmotion and moved it to a folder and it installed . When I click on it to run it come up with a error (MSVCP120.dll is missing from computer) I tried to reinstall it as it asked me to fix this problem but came up with same error.

There’s an article on this:

If that doesn’t help, either let us know, or contact

It seemed to work the program will open . It asked me to connect cutter and I do not have it connected to anything and it came up with error(cutter not found) is that normal .

Yes, Carbide Motion uses the USB connection to the machine as a check as to whether or no it will run — once you get the machine connected (the Arduino will power itself from the USB) it’ll allow you to go on from there.

Great Thanks for the help.


It sounds like yo need some training. I recommend:

yep thanks agsin I still am waiting on a few missing parts to get shapeoko 3 completed