Spindle won't start

I tried to start a tool path on my Pro XXL and the machine acted like it was going to start. It moved to the correct starting position and started to descend to the work piece, but the spindle did not start up. I had to hit stop to keep it from crashing into the work piece. The VFD is showing 91.5 on the display. Not sure if that’s an error code or what.

Any idea what I need to do?

Based on a recent event of my own, the very first thing I’d do is check that all connections are secure from the mainboard to the vfd, then from the vfd to spindle.

My connection looked good at the mainboard but turned out it wasn’t making solid contact. All my issues seem to have went away since I reseated it. For reference; normally the vfd showed 0.00 on the readout - while experiencing my issues it displayed various readings.

Good luck.


I unplugged both ends of the VFD - controller cable, checked the ends, blew them out, and replugged. Did the same thing to the Spindle connection. Still no joy.

I have no clue what any of the buttons on the front of the VFD do. I’ve tried to find a manual that covers that with no luck.

Also I found that the display shows a different number:
M3S25000 displays 399.5
M3S20000 displays 334.5
but in either case, the spindle does not spin-up.

I have no clue what these numbers mean or if they are even a concern.

It worked perfectly as recently as yesterday.

I got some help from the Fusion forum on a toolpath I was working on, and the member sent my file back to me with the corrected toolpath. I looked through the toolpath to see if something changed, but didn’t find anything to be concerned about.

If you press the JOG button on the VFD it should make the spindle turn at 1200 rpm. If it does, it’s likely something with the VFD to controller link. I just got mine back yesterday from repair, they had to replace the interface board to the SO5 controller.

Thanks Travis,

I pressed the JOB button on the VFD and it quite quickly counted up to some number and counted back down to 0.0 It happend so quick, I can’t tell you how high it got before coming back down. In any case the spindle did not turn.

I guess I should contact support if no one has any other suggestions.
Not sure what the “interface board to the SO5 controller” is. (new guy)

1 Like

Yes, contact support. FWIW the board I referred to is the circuit board inside the VFD box that the cable from the SO5 controller plugs into.

Section 6.6 of the manual suggests that is the VFD’s “Set Frequency (Hz)” (1/60 of the set speed 8,000 - 24,000 RPM). Carbide 3D support should be able to verify that. :wink:

1 Like

Well, another “stupid user trick”. Turns out that I did not notice that the red light on the VFD was out (and therefore the spindle was off). I noticed that the display was light and didn’t even see that the enable button was not depressed. It wasn’t till the guys at support had me take some pics of my setup that I noticed in one of them that the light was out. I’m starting to feel like the old man that cried wolf too many times. but fortunately no one has given up on me yet.

Thanks for your responses.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.