Suck It Dust Boot

I’ve been using the PWNCNC dust boot for a few months and keep running into issues with it because it drastically reduces z-height. While it works great for thin sheet goods, it doesn’t work well with thicker parts. I wanted to order a Suck It dust boot to have better success with certain parts but it turns out they look like they won’t make dust boots for Shapeoko or X-Carve anymore with their transfer/acquisition into Onefinity CNC.

Does anyone know of any other good z-independent dust boot options?

Time to design your ideal dust shoe and 3D-print it ! :slight_smile:
I really like mine, it took a good 5 or 6 iterations as with most custom designs, but having it exactly as I want is invaluable. Oh, and it’s more efficient than the Suckit I had before.


Yeah, I may end up copying your file and giving that a try. I’m just in a scenario where I would love to make projects rather than more tools to make projects.


That surprises me as I have one also. What are the particulars of your issues?

I’ve had 4different dust boots and have good luck with the suckit and PWNcnc’s. After installing the HDZ I ordered retrofit parts and was in good shape. But, after I purchased the HD mount I’m back to square 1. I will probably put my Chinese dust boot back on. It’s just a little heavy. If I had the knowledge and tools I’d make my own.

1 Like

Many people like the Suckit Dust Boot. I bought a clone and did not like it. I have had two versions of Tite-CNC dust boot I bought on The first one worked well but had a tiny dust port (1.25") and the dust skirt was made of some rubber looking material that tore up and got sucked up inside the dust boot. I ordered a newer version and it has a 2.5’ dust port and they put bristle brushes on the magnetic dust skirt. The bristles were a little long so I trimmed them with a pair of scissors. The Tite-CNC dust boot is the type that fits on the bottom of the Dewalt router. Overall I am happy with the dust boot and I think the vendor will make a custom one. The second Tite-CNC dust boot came with another base/skirt that is solid except around the bit and has a cone shape. I have not used that one and with the bristle brush skirt I get no sawdust left behind. This picture was with the original Z axis, I have since upgraded to the HDZ and the dust boot still works well.


Although I love when I’m finished making tools because then I can put them to work, I’m always chomping at the bit to get to making actual projects, so I hear you!

I recently switched over to the HDZ, and I’m at a crossroads with a dust solution. Having the Suckit Pro, and low expectations of retrofit kit availability, I’ve decided to fab a retrofit to get me back to at least where I was. At the end of the day, I think Julien is correct as the old adage goes, if you want something done right, do it yourself (or when in community.carbide3d do as the @Julien does).

By the way, thanks for mentioning the shortcomings of the pwncnc dust boot as I have looked at that option.



I ordered the retrofit duck it kit after installing the HDZ and all worked well. After installing the HD spindle mount is a different story. I went back to using the PWNcnc dust boot with the Suckit mount and am now back in business.

Would you mind sharing a picture of your setup?

My problem is that I lose so much z-clearance with the hose going under the x-gantry. The hose is constantly catching on clamps and material and pulling the boot off.

Yeah, I have one of this style already and was just looking for one that mounts independently of the z-axis so when I am working on 3D contouring parts 2 inches high, the bristles stay at a constant location.

Yeah, this is what I’m afraid of. I also don’t have a 3D printer at my disposal so that makes it hard to iterate on designs as easily. I think I’ll start with Julien’s design and go from there.

I’m surprised you haven’t bit the bullet already. I tended to think of 3D printers as novelty items, but lurking hard on this forum, I’ve seen enough real utility that I justified the plunge.

I looked at threads on this forum, including the one where you mentioned Ben Myers recommending an Ender 3. At first I dismissed that machine, correlating the low cost with low performance, but I ended up buying one and doing some of the upgrades that @themillertree mentioned (metal extruder and heavier springs). I wanted a Prusa but lead times and cost of something I still wasn’t sure I’d be into led me to the Ender 3.

Arrived this past Friday, set it up, and started test printing in hours. By Sunday I was printing prototypes for my SuckIt retrofit!

I bought the machine for $189 shipped and bought a $30 upgrade kit with the metal extruder, PTFE extruder tube, and heavier bed springs. I’m amazed at the performance for what I’ve invested. I can easily spend that much on just a couple of cutters for the SO.


Yeah, I understand the utility and my brother bought one and loves it too. I will buy one this year, I just need to figure out where I am going to put it…

I’m using the PwnCNC dust boot. I 3D printed it myself from the files he posted on Thingiverse. I have a wall right behind my XXL and the rear exit hose did not allow the gantry to move all the way back. So I designed and printed a 90° elbow for the vacuum hose (the blue part in the picture). This also allows the hose to route better to the clip on the top (the red part) and is probably less likely to drag on the workpiece.


Nice! That would help out nicely on some of my parts. Would you share the file with me and I can see if I can get a friend to print it for me.

For folks who don’t know anyone with a 3D printer, 3dHubs is worth checking out for single run parts you want printed, machined etc.


I’ll put it up on Thingiverse and you can download it from there. I already showed it to PwnCNC and he liked it, so I don’t think he’ll mind me sharing it, since it’s derived from his straight hose fitting.


I finally got around to putting the 90° elbow on Thingiverse for anyone using the PwnCNC v2 or v3 dust boot. Here’s the link:

1 Like

Maybe have to wait more than an hour? All I get is a 404 error page.

EDIT: 2 hours in and still getting the 404 error page.