The router bit raises on "Run"

As soon as I hit Run the router raises about 3/4 of an inch then proceeds with the tool path well above the stock. I am very new to Cam, I have been using Fusion for a few years for hobby 3d printing.
I have a shapeoko standard.
I am using Fusion360 to model and create tool paths and GCode.
I am pretty sure my problem is my setup in Fusion but I can’t find where this behavior is coming from.
Carbide Create works great, not problems. Some of my Fusion projects work fine.
Any help is appreciated. (26.4 KB)

You would seem to have the stock origin defined as being the surface of the wasteboard, but seem to be setting zero at the top surface of the stock — please make those two things consistent.

1 Like

I’m with @WillAdams on this. Looking through your code, all of your Z movements are positive. Your Fusion setup must be from the bottom of the material, and you are actually zeroing from the top.

Should my origin be on the stock top? Or are you saying the two need to be the same.
If My model origin is on the bottom and I use model origin in the Heights settings should that do the trick?
If the stock origin is on the bottom will my top height be a positive or a negative?

Are there tutorials for learning how to read g code?
BTW thanks for your time and help.

The setting in the file, and how you set up the machine to run the file have to be consistent.

The great thing about CNC is that given a correctly prepared file, it will cut a correct part, when the machine is setup to correctly to cut the part, and nothing goes wrong.

The awful thing about CNC is that in order to get a correct part, the file must be correct, the machine setup must correctly match the file, and nothing must go wrong in cutting.

1 Like

To read G-Code I would recommend a previewer such as CAMotics, and see and

Follow Will’s links…
To keep it really simple, think of High School Geometry class. G_code stands for geometry code. The Shapeoko and most CNC’s work in the positive quadrant of the grid. Right is X+, Forward is Y+, and up is Z+. Everytime you see a “G1” in the code there is a linear(straight line) movement to a coordinate. “G2” there is a clockwise circular movement, and “G3” there is a counter clockwise movement.
This is enough info for you to see which way the machine is moving.
All of your Z movements are positive, so the machine was going up from where you set your 0,0,0

Hope this helps a little. But follow Will’s links.

1 Like

Your model origin doesn’t matter unless you want it to. The work origin is set in the setup, not the toolpaths.
If you set it at the bottom of your stock in Fusion, you should be zeroing your Z on the wasteboard.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.