Tool path not starting at desired start point

Hello, I am very new to this. I have been using vcarve pro to make some basic designs and have had good success with the shapoko cutting out shapes that I have designed in vcarve. However, I have started to attempt text and whenever I send my project to carbide motion and go through all the normal setup as i do with the other projects, for whatever reason the spindle moves -x and -y some amount off of my material, I have tried to edit my point of origin through vcarve and attempted multiple different text and have had no luck. But cutting out a shape is no problem. What am I doing wrong,

Hi @toddnpti81,

Can you post an example VCarve file that’s giving you trouble (.crv file), as well as the associated G-code file you generated and use in Carbide Motion ?

VCarve does not handle text differently from any other shape as far as toolpath reference is concerned. Everything in the project will be referenced off the zero point you setup.
How much is your X and Y off ?

Hi i am trying to upload the files but it says i can’t upload the crv or gcode files. how do you folks normally share those files on here? and it is generally a good -5,-5 inches off everytime, that isn’t exact, but it is fairly close

Please zip the files and then post them.

hobson (173.9 KB)

thank you for the tip.

Thanks Todd,

I don’t have access to VCarve right now to check the design file, but I checked the G-code and it has the zero reference in the lower left corner of the stock:

That seems ok to me (this is quite typical) if this was your intention, but maybe you thought you had the zero set at stock center, not lower-left corner, and this is why you think you have about 5 inches of offset ?
(from that preview, the center of the text is roughly 5inches to the right and 3 inches towards the back from the zero point)


yeah that is how i had intended it. so when i set the machine it is set to the lower left corner, but when i start the cut the machine moves to a different point. i have tried to reset the offset and origin point and regardless of where it set the router moves to the same point. I dunno, I’ll try scrapping it and starting over.

When you retry this, can you make a note of how you set the zero precisely and report here ?
There might be something wrong in the procedure you use. If you set the zero correctly and load that file you posted, the first move should be one of those diagonal red lines



Vcarve seems to validate your story too, allot of us are having issues with Vcarve gcode at the moment, out of curiosity did you generate this on Version 10.5x?

am just finishing a job on my machine then i will try and run this to see what is happening on mine :slight_smile:

Also “What am I doing wrong,” - Nothing :slight_smile: you are learning my friend, and there is nothing wrong with that!!

Let you know how i get on


1 Like

Ok so it was fine on mine, no issues sadly so as Julien says must be something you are doing to zero. Post back with your zeroing workflow and let’s see what is going on !

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.