Tool paths keep disappearing

I don’t know if it is me getting crazy or what, but something strange is going on.
I create my simple designs in Carbide Create, do all my list of too paths and inspect if everything is OK. Because I have lost many files in my life I am used during the different stages of the project to do progressive savings, like 001, 002, 003, etc. so if a file get corrupted I can still work on the previous version.
What is going on is that after finishing my project and save the .nc file I obvious ly close the Create file, but when i reopen it in the same workstation or in the laptop connected to the Shapeoko i find a varying quantity of Tool Paths EMPTY! at this point i don’t know if the .nc file is good or not. If it can be used or not, Sometime more than half of the paths show empty in the Create file.
I got my Shapeoko 3 XXL about two weeks ago and this has being going on since the first day, beside saving I don’t know what else to do.
Just a side information I have been working with graphic software, cad and 3d software for the last 30 years so I am not new.
Thanks for your help
Alfredo Malchiodi

not sure I can help you with the Carbide Create side, although I don’t see this…

… but if you want to see if a .nc file is sane, I can recommend the “Camotics” open source software, or the website.

1 Like

I have this same issue, when I run it through Camotics the file is empty. Most of the time i find this happens on an nc. file that i have not run yet, however I have had this happen on some files that were previously cut multiple times. I just build the tool path over again because they are small and don’t take too long.

Thanks for your reply, I tried the ncviewer website, but it is difficult to see if everything is there when I have multiple paths nested one on top of the other. The problem is till in the Create side.

Thanks for checking in, this make me feel a little less crazy. I have the last edition of the machine and of the software, no much i can change.

I suspect that the support folks wouldn’t mind an email to them with some basic system info things… there must be something weird going on since many of us use the tool just fine… so … what’s different…

1 Like

One thing I’ve argued for is that math in the program be done using integers as in TeX so as to foreclose on the possibility of rounding errors (yeah, I also think accounting programs should be written in binary coded decimal — it’s a good thing I’m not financially responsible for development of anything which needs to make money).

Yes, we would appreciate any repeatable bug with step-by-step instructions on causing the problem.

You mention the latest version but there are so many versions being tested at the moment, maybe you should indicate which version of Carbide Create you are using just to be sure. If you have not done so, there are several Beta versions in test and you may want to check if you are using one and if you have the latest.

1 Like

here are the versions:

Carbide Create 451 2020-01-30
Carbide Motion build 4.0.428

Carbide Create is at ver 460 now if you want to try I know they fixed some issues. Maybe you want to rename the old version so the new does not overwrite.

Carbide motion should not be an issue for your problems.

1 Like

Hi William,
I am not sure i understand what you are talking about mentioning integers and binary.
I do my measures in mm and the maximum in precision i go down is decimals, but i know that this is not what you are talking about.

The repeatability of this bug is simple, close and reopen the file.

If 460 is a beta I like to stick with releases.
I know that Carbide Motion is not the problem, but empty tool paths are transferred to it.

Send the file in to us with instructions on how to reproduce it and we’ll try to have a developer look into it.

The integer/binary thing is idle speculation on my part.

tell me where to send the files

I sent few files with the empty path problem to support at your attention.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.