Trouble with first set up / CNC not responding to CM JOG feature

I was able to use the JOG feature in the CM software a few time and was able to move in X Y Z. but now I started the machine again and when I go to press any keys in the JOG page the router goes in the top right corner and keeps going with a bad noise until I get an Error and the system shuts down. Does thats mean that the limit switches are not responding? Please Help !


Not a lot of information to go on, but let’s start at the beginning. Has $20, 21, and 22 been set to 1? (Homing, soft limits, and hard limit, and has homing been set (on the setting tab in Carbide Motion)? And do you know how to get this information?

Hi Rich, thanks for your help

I did run the SHAPEOKO Box-Logo trace file successfully.
In some of the other test I did I would just position the gantry manually towards the middle of the Wasteboard then turned on the CNC, then in CM set the x y and z coordinates to Zero All and the . I did choose the Toolpath to zero in CC before loading it in CM.
No I didn’t know I had to set the $20 > $22 to 1. I don’t even know what you mean by $20, seems I’m missing an important step . What do you think?

Ok, let’s take this one step at a time. Did you install the limit switches? Because I see another post from you that lead me to believe that you installed the switches? If you did, you need to tell the machine that they are installed.

What Rich said - you don’t need to set $22=1 if you don’t have the limit switch kit installed but you do if you do…

Did you install a limit switch kit?

Also, check which version of Carbide Motion you have - especially if you updated it after running programs successfully. Several people had a similar problem with the newest version (362). I was able to fix mine by reinstalling 361.

Yes I installed all 3 and changed the Carbide Motion Setting value to True for the Shapeoko has homing > True
then I clicked on Jog and it prompted me to clink to begin Homing but then I got this error message: GRBL error: setting disabled

I tried 5 times and got the same error message, that’s as fare as I got ;(

Ok I can try that, where do I get the oldest CM version 361 I don’t see it in Carbide’s download software section


You need to change the setting inside of GRBL. Didn’t the switches come with instructions?

Ref $20, $21, $22 need to be changed from 0 to 1

FYI- Edward was able to duplicate the strange jogging in 362 and we were able to get it fixed. If the testing is good, 363 should be available today with jogging fixed.



To change the Home settings, click on the MDI button (I think it’s MDI, I can’t open the program right now because I’m not hooked to my machine). In the blank space next to the SEND button enter $20=1 and hit SEND. Then $21=1 and SEND then $22=1 and SEND. Now if you enter /$h in the same space and hit SEND your machine should try to HOME itself.

If you go back to the main screen and hit the INFO button (once again, this is from memory - it should be the far left button) and push the L key on your keyboard, you should get a log screen showing communication between your computer and the S3. Go back to the MDI screen and enter $$ and you’ll get a list of your current settings where you can check to make sure the values for $20, $21 and $22 changed.

BTW, I only changed $22. I’m not sure what the other two do but my homing function works great.

PS - here’s a directory I found with all of the Motion versions