Trouble with Mac

Is anyone using a Mac to successfully run carbide create in macOS Big Sur, 11.0.1?
I’ve watched the tutorials and understood most of them after I watched Ben Myers’ Shapeoko tutorials, but I’ve yet to successfully complete even the clamps project.
Starting to wonder if I’m like the old joke about being too stupid to own a computer, or in this case a CNC.

Not Big Sur, but run CC and CM on my iMac, without issues. Also run VMware Fusion hosting Windows 10 for Vectrics VCarve and an ancient copy of Solidworks, all running at the same time.

Is you Mac one of the new M1 chip machines, rather than Intel chips?

Mac OS X 10.11 is not supported in current versions:

If you’ll contact us at support we should be able to provide a link to a version which works in that older OS.

If you currently are running Carbide Create, then there’s no reason for it not to work — have you tried working through one of the tutorials?

I run: MacOS Sierra, version 10.12.6 (mid 2012)
Carbide Create Build 464
Carbide Motion 359

work great


1 Like

Are you running the latest build of CC 514?

What are the issues you are having?

OS Big Sur is the latest Apple operating system. I’ve been thru the CC tutorials a few times. I liked the ones from Myers Woodshop. Before this I’d considered myself reasonably competent technologically.

Thanks Andy. My Mac has the intel chips. It’s a couple of years old.

Please post the Carbide 3D tutorial you are having trouble with and let us know step-by-step:

  • what you did
  • what you expected
  • what actually happened

I just loaded CC 514 last week. Since I asked my problem about Mac, I bought an inexpensive laptop a step up from the one that Ben Myers suggested on his website. It is a Windows 10 platform. I thought that would help. Sadly it didn’t help, but it did eliminate Mac as the problem.
My issues currently are that I can’t get carbide motion to run the design that I created in CC. I wrote down what happened step by step after trying several times. If this is too much please look over my inexperience and ignorance.
In Carbide Motion and after zeroing the axes clicked from Jog to run.
Loaded file, selected open, turned spindle on.
Clicked Start Job
Run Job pane popped up
Clicked Start - no movement. The pane displayed: Code MO; T302 at line 4 of 12
Since there seemed to be no other instructions, I clicked start again.
small pane pops up announcing Spindle change required
spindle increased to 3 (18,000 rpm) as instructed
clicked resume
Machine travels to just above the center
another small pane pops up announcing Spindle change required, turn off spindle.
I complied, then turned spindle back on and hit resume having already checked for correct bit.
Spindle raises up and Job info pane pops back up
and the cycle starts over.

I have no clue, but would appreciate any insights.

Please try working through one of the official tutorials:

and review:

If you have difficulties with an official tutorial let us know;

  • what you did
  • what you expected
  • what actually happened

and we’ll do our best to work through it with you.

Will, I may not have made it clear in my original post, but I did go through the “official” tutorials. Several times actually. Seems the official tutorials were made with a slightly different version of Carbide Create than the recent 514 build that I downloaded. For my part, the key commands that are being used are not clear to someone who is totally new to CNC use. A written version might be easier for some of us to follow along. Granted, my hearing has some limitations.
What I did. I wrote a program for v carve to inscribe Merry Christmas in hardwood.
What I expected. I expected to have a piece of wood that read Merry Christmas
What actually happened. A little bit of movement, but not even any wood chips. Nada.

@Adhmad, that line caught my eye.

You should not have an M0 in the G-code if you use the correct post-processor in Carbide Create.

Can you confirm you have a Shapeoko ?

If so, you should go in “Edit” menu, click on “Select Post-processor”, and then select the “Carbide3D Shapeoko” post-processor there. Then, save your G-code file again, and try to run that new file, it should work much better.

1 Like

Please let us know step-by-step as you work through the tutorial. Moreover, the tutorials at:

are not videos but text — please copy the text step you have trouble with and note:

  • what you did
  • what you expected
  • what actually happened

and we will do our best to work out any difficulties or get the text updated/corrected.

The only notable mismatch should be that control is no longer used for multiple selections in CC, rather it is the industry-standard shift key.

While it’s for the Nomad, you may find it helpful to review:

which uses more up-to-date versions of our software.

If the problem is cutting in the air, then that is usually caused by a disconnect in how you are specifying the origin in your file and how you are setting zero relative to your stock.

Please post a .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero relative to it and we will do our best to work through this with you.

For an example of a V carve tutorial in current versions of our software:

  • launch Carbide Create:

  • click on Job Setup:

  • set your stock dimensions and units and origin as desired

  • OK

  • create something which will be V carved, say a bit of text:

  • click on the Toolpaths pane:

  • click on VCarve while the desired geometry is selected:

  • Tool | Edit:

  • Select Tool and click on disclosure triangles until one selects the desired tool for the given combination of machine and material:

  • OK | OK | OK

  • Set simulation settings appropriately and click on “Show Simulation”:

  • adjust as necessary until the appearance is as desired, then click on “Save GCode”
1 Like

Secure your stock on the machine, launch Carbide Motion, power up and connect to the machine, load the desired tool (if using a BitSetter using the tool change interface), set zero relative to the stock to match the file you have made and then run the file.

Julien, you Sir are brilliant! I followed your suggestion and I am now successfully running my programs. I can’t say thank you enough.
Best wishes to you and yours for the holidays. David.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.