Trouble with... well I don't know what's causing the problem


Absolute noob to Shapeoko and CNC. Hoping for a little guidance.

For the record, I am using Carbide Create and Motion.

I got my Shapeoko XXL about a week and a half ago and put it together, following the directions meticulously. Most of the cuts have been very solid, however there is one program that doesn’t seem to play nice and I can’t figure out why.

The initial plunge depth is way to deep. All other cuts are at the proper depth that I set. On a diagonal cut it produces a wavy line. I’ve attached the CC file.

It also cut all the way through 1.5" stock when I only told it to go down 1.25".

I could really use some advice.

Thank you.

CNC Side Brace.c2d (8.0 KB)

Here’s the end result.

Did you zero your z axis with the touch plate?

1 Like

Unfortunately I don’t have that toy yet, but will be getting the touch plate as soon as they’re back in stock.

I did, however, use the piece of paper method to zero the z axis prior to running the program.

For this particular cut - does the tool you’ve selected in Carbide Create match the tool you’re using to actually cut?

If there is a bit change involved (between this poor cut and the other good cuts) - did you re-zero your Z after the bit change?

Is the material thickness on this cut/file the same as the actual material thickness? Is it the same as the material thickness set on your other cut files?

The waviness - is the cut rate too high possibly? Maybe if the plunge depth is too great (caused by an error above) the machine is pushing the tool beyond it’s limits and you’re getting flex? How much of the tool is sticking out of the router - more than required causing flex?

Is there any play in any of your axis that would allow flex? Maybe its only small and not being triggered in other cuts but this one where it’s cutting too deep you’re seeing it?


Yes, the tool matches. It’s the #201 1/4" end mill bit that came with my machine. I just double checked the CC file and it is using that bit.

No bit change is involved.

Yes, the material thickness is the same. I’m using a piece of 2x10 which is 1.5" in thick. This is what I have setup as the stock thickness in the job setup. The cut is set for 1.25" deep.

I’ll try dropping the cut rate. I have just over 1.5" sticking out of the router.

When I grab the router it’s solid in the x axis, but has a bit of play in the y axis. Basically it rocks a bit forwards and backwards (hope that makes sense). Is there a way to tighten down the x axis assembly on the extruded beam?

Check out here for installing the X/Z carriage and tensioning the V-wheels - which will hopefully reduce that slop


Thank you. I’ll give that a try.

What about that initial plunge depth? Any idea why that’s happening?

By the way, I just tensioned the V-wheels, and that seems to have gotten rid of the slop.


My best guess on plunge depth was the zeroing of the Z being out - but if that’s not the case i’m not sure…

I also opened your file you attached but it doesn’t have the toolpaths generated, just the design itself. There’s nothing weird about the design - it’s very straight forwards. Can you attach a version with the toolpaths generated?

When I first got started I had some confusion on Zeroing axis’. You have to first click the Zero button to bring up the dialog of where all 3 axis zeros are but then you have to click again on the axis you actually want to zero.

1 Like

Don’t know if this is issue. I had a similar situation happen. So I doing a waste board trim, and only going down .003 to trim the waste board. I seen it was not the right depth, so I paused it then stopped the job.

So I changed my setting to cut a little deeper say to .006. Thinking it it was already Z from the last run since I have the touch plate, I ran the job. Well It wen t down more than .006, ruined the waste board and had to start fresh.

So some where the Z got mucked up, so now I re Z everytime if I pause and stop a job. Probably a bug in the code

Do you hear the Z hit the top before the job starts cutting? If so, it thinks it is higher than it really is, therefore goes too deep


I’ll check that when I get home tonight.

How would I fix that if it is happening?

Thank you,

Generally speaking, 3" is kinda the max distance from the wasteboard that you have to work with. So if you have a supplementary wasteboard on top of the stock one, that cuts that down by the thickness of your wasteboard. So with 1.5" of material on top of that, and a stickout of 1.5" on your bit, you’re going to run into issues. The Z Carriage is going to run into the top of the X/Z carriage and your belts will slip. The machine will think it’s higher than it actually is. One fix for that may be to loosen the router mount so you can slide the router up a bit, then tighten it so it stays there. I’m not sure about the stability of doing that, someone else will have to weigh in on that…

You can see from your picture that the first cut is way deeper than the rest… so the machine is starting lower than it should, then continuing on as if it was normal. Deflection is causing the wavy line from that first super deep cut, and the subsequent cuts are being forced to follow it.

This is a good pick up - nice one.

The other thing - and it may just be the angle of the picture, or it may not - is that the depth of the first cut appears to change along it’s length? Is it possible the material your cutting is not a uniform thickness and you’ve zeroed in a thinner area, and started cutting in a thicker area?

So I finally got great cuts!

I removed the T-Track and clamp kit in order to get more vertical work space, and tightened down the wheels on my X/Z carriage. After that I got beautiful cuts that were exactly what I was expecting.

I have to say, everything I heard about the Carbide 3d forum, the helpful Carbide 3d staff, and community in general was a big part of why I chose to go with the Shapeoko vs. the competition. I’m now more convinced than ever that I made the right choice.

Thank you everyone for your help!


I just don’t get it. Every problem I’ve had with hardware and software has been taken care of from the support folks. Guess I’d complain if I just wanted to give up my XXL. But I don’t!

So I’ll keep learning and improving and even finish some Christmas gifts. :grin::sunglasses::palm_tree:


1 Like