Unable to Use Carbide Create after Switching Laptops

Background: I have been using Carbide Create with my Shapeoko 3 XL without any major issues since March of 2017. Last month I switch to a new laptop, a Dell XPS running Windows 10. After downloading Carbide Create (Build 313) from the site, I am met with the familiar sight of Carbide Create, but the scale of the menu and work space is incorrect and the buttons are inoperable/misaligned from the label.

I included a screenshot in the following link: https://imgur.com/gallery/gLH7J

I am wondering if there is a way to fix this issue.

We’ve been trying to figure this problem out. From what we can tell, it’s a problem in the Qt framework that we use for all of our apps or some problem with Qt and the latest Windows 10 update.

Also, it seems to only affect Dell computers on Windows 10 (everyone who’d reported a problem is on a Dell XPS 13 or 15), and the app seems OK on a Microsoft Surface running the same OS and a similar DPI.

We’ve got some more testing to do before we go to Qt to confidently report a bug but I think the first recommendation we have is to check for updates to the video driver.

Does your XPS have the standard screen or the 4k/Hi-Dpi version?

1 Like

As an additional datapoint, it was okay on Windows 10 Fall Creators Update on a Samsung Galaxy Book 12 at 2160 x 1440 — the only glitch on that was not being able to select drop down menus using the stylus.

I just had a thought about the problem after typing that reply and I think I’ve got a partial fix on my Dell XPS 15:

  • If I open the NVidia control panel and set the preferred graphics card to “Auto” or “Integrated” then I get the shifted rendering.
  • If I set it to “NVidia” then the program work as expected.

Can you try this out and see if it helps?


I was having the same exact problem after switching to a new Samsung laptop running on Windows 10. None of the suggestions on the forum worked. I stopped trying and after a few days of Windows updates to the laptop, the problem was “magically” resolved. I recommend making sure all updates are installed and give it a couple of days.


Sorry for the late response.

I have a Dell XPS with a 4k display screen.

Thank you for the suggestion with using the NVidia control panel. I am unable to find the NVidia control panel on my laptop. I will be looking for solutions in finding this panel during my free time today.

On my machine the NVidia control panel has a small icon in the tray at the bottom right corner of the screen.

One option you can use until the issue is resolved is to change the resolution to 1920x1080. I’ve had issues on 4k laptops with other software where graphics scaling did not display properly.

By switching to 1920 x 1080 your graphics won’t look as crisp, but it should eliminate that issue until an update is pushed out.

1 Like

I was able to get to the NVidia control panel (my drivers needed updating) and switch the preferred graphics card to “NVidia”. This has solved my problem and I am currently back to designing pieces on Carbide Create.

Thank you so much for your help!

1 Like

Thanks for the feedback Eric. Hopefully the problem will be fixed in the next Dell driver update so CC will work with the integrated GPU as well.