Unnecessary z movements

Attached is a file which creates G code (also attached) for z movements for each layer of the outer 5 mm radius circle. It mills a layer, then it goes up a centimeter and down again, then the next layer etc. I guess could be at least 3 times faster if it wouldn’t do it. Looks like for the 3 mm radius circle it doesn’t do this. Can I prevent this for the outer circle as well?
hole.c2d (3.7 KB)
hole.nc (140.6 KB)

By doing geometry selections and setting toolpaths as optimally as is possible in Carbide Create one can reduce this to some extent. Lowering the safety/retract height helps as well.

There are 3rd party tools for optimizing toolpaths (listed on the wiki, but it’s down last I checked, should be back up some time today), but you’re on your own for that sort of thing I’m afraid.

1 Like

The more you work, and the more complex the cuts you do, the worse this gets. This is one of the big reasons I moved away to other tools that optimize better.