Updated to CM4, existing NC file now fails

I updated from CM3 to CM4 today (build 412). Now an existing NC file (attached below) generated by Fusion 360 that ran to completion on my Nomad classic fine earlier in the day using CM3 now fails after a while of running with this error:

ERROR (2): GRBL ERROR: The motion command has an invalid target. G2, G3, and G38.2 generates this error, if the arc is impossible to generate or if the probe target is the current position.

charger_bottom 4.nc (80.1 KB)

Please send such problem files in to support@carbide3d.com and we’ll see if we can add them to our test suite or have a developer look at them.

To fix this problem try:

  • regenerating the file using mm instead of inches
  • turning off ramping in moves
  • disabling the generation of arcs

I’ll send it to the support address.

Regarding the workarounds:

1.) I always work in mm and as shown in the settings screenshot, everything is already in mm. Might the other way around also work, i.e. regenerating it in inches?

2.) I don’t think I have ramps but I’ll check

3.) I couldn’t find an option to disable generation of arcs. Do you happen to know where to do that in Fusion 360? Is it one of the options shown in the screenshot above?

We’ll try and take a look at it tomorrow. We’ve been making changes to the arc handling to make sure that arc errors are caught before they are sent to GRBL so this error seems odd.

I just realized that this seems to be the same error that I already reported back in April when beta-testing CM4:

I sent you an NC file at the time.

Just off the screenshot is a “Properties” tab - I can just barely see the top of the arrow in the shot there. Expand it. Uncheck “Allow helical moves”

I’ve been generating a lot of gcode with fusion the past few days, and have had WAY more problems with crashing fusion360 messing with the different operations than the actual output. I think I must have crashed it 50 or 60 times in the course of two days. I think it has something to do with .SVG derived features.

1 Like

Thanks for the tip Mike. That “allow helical moves” checkbox was indeed checked (click on the screenshot image to see the full window).

I regenerated the gcode with the checkbox unchecked and everything else the same, and unfortunately it still fails the same way.

Ok, well then I’m at a loss - that’s all I do.

Maybe the difference is the machine? I have the original Kickstarter Nomad. Do you have the Pro?

Shouldn’t be unless you have different versions of Grbl flashed.

1 Like

Is there an update on this? Did you get a chance to look at it? I noted this exact issue last April and it’s still preventing me from using CM4 with output produced by Fusion 360.

I have an SO3 but, since I installed version 412 of CM I’ve encountered zero arc errors with F360 files.

I see from your original post you were/are running 407. Sorry, I don’t have a link handy, should be easy to find though

1 Like

CM412 if you don’t have it is available at:


Yes this is still happening with CM412.


Is CM4 considered finished, or still beta? Is there a newer version than 4.1.2 that I can test? Can you reproduce it with the test file I gave?

Your file is running ok on my XL. So far. I don’t have time to run the whole thing.

Just stopped it, still no errors.
CM 412, stock F360/post processor.

1 Like

Thanks for the test!

I have a Nomad, not a Shapeoko. A test with a Nomad (classic) would be more interesting.

I’m sure the Carbide guys could run such a test.

Will, could you run a test on one of your Nomads? This is 100% still reproducible, and I’d really like to upgrade to CM4, in order to get the speed-up/slow-down feature.

Ran that through line 500 or so using 411 before l stopped it.

Running on 412 now EDIT and it finished w/o error.