Upgraded Software Router plunging immediately

I just downloaded Carbide Create Upgrade (Build 474) for Apple to run my Shapeoko XXL. Now when I start a job in Carbide Motion, the machine snags momentarily and then plunges the router deep into my workpiece. Before the download everything was functioning normally.

Any suggestions on what I’m doing wrong?

Did you also upgrade your Z-axis?

Have you resent the machine configuration in the Settings panel?

If so, is it possible that your previous setting was customized to reverse the Z-axis? If that’s the case, then you should rewire the Z-axis stepper motor by powering down and swapping pair of wires (left or right pair) or otherwise rewire to reverse the axis (best if you make it match the other motors if applicable).

If that’s not it, let us know the specifics at support@carbide3d.com and we’ll do our best to sort this out with you.

I only downloaded the software. I did not consciously upgrade my z-axis. I don’t know what it takes to upgrade my z-axis.

The settings panel shows a Shapeoko XXL in both Carbide Create and Carbide Motion. Are we talking about both?

Where would the customized setting be to reverse the z axis? Are we talking Create or Motion?

Did you resend the configuration in the Settings pane in Carbide Motion?

The customized settings might have been made in Grbl — there are bits there for reversing each axis.

Also, is the Z-axis homing switch engaged? Either because the carriage is at the top or the switch is stuck on?

I don’t know what you mean by “resend.” I assume that you mean “reset?”

I assume my homing switch is working since I am getting data on screen for all x,y and z coordinates.

As for cusomized settings might have been made in Grbl, that’s way over my head. All I know is that my machine worked fine before the upgrade to Carbide Create Build 474. Now it’s useless.

Please contact us at support@carbide3d.com

Let us know what you did, and let us know step-by-step what happens when you initialize the machine.

Thanks, I did. Just so you know, however, I just tested a g-code that I created last week and it ran fine, so I don’t think it’s the machine. I also checked my settings again in Carbide Create and resaved the g-code but I keep getting the same result - router is plunged into the workpiece almost 11/16 and it tries to start cutting (I’m trying to cut a simple mortise).


The post processor may have been deselected when you upgraded, you should go and check in CC in Edit/Select Post-Processor menu that “Shapeoko” is selected, not “GRBL” or “Basic G-code”


1 Like

I figured it out! Although I reverted back to Build 464, I got the same results. It turns out that my retract height was beyond what the z motor could attain. That was the “snag” that I was hearing. My retract height had been set to 1" because I wanted to make sure I cleared a clamp that’s holding my work piece down. When the machine moved into it’s x,y position to make the cut, it lost orientation relative to the z-axis when tried to retract over the work. Since I’m working with a thick piece, the router was already near the top, it got confused when it tried to raise up 1" but couldn’t. This apparently confused the machine to the point that it plunged down nearly 3/4" into the workpiece. I reset the retract height to .2 inches and it’s working fine.

Thanks for your help! I’ll upgrade back to Build 474 and try it again. I’m sure this was the issue though.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.