V-Carve Pro dxf file

I see the subject has been raised here. What I’m experiencing is I can open dxf file that I purchased (CNC cut files for some furniture) in Carbide but the it opens in millimeters and also shrunken in scale. If I double click the file from my desktop it opens in my “Trial” version of V-Carve Pro in inches and correct scale but I can’t justify purchasing V-Carve at this time.

I’ve shot off an email to Vectric to see if the vendor I purchased it from can simple choose a command on his end to make the file open correctly in Carbide. I’m trying to remain positive but you know how that goes.

Anyone here got their arms around this? I’ve managed to change units in Carbide to inches and then resize with Scale factor or manual width and height commands but it’s hit and miss.


The scaling factor should be consistent — send the file in to projects@carbide3d.com and we will look into this with you.

Send me the file, and I will fix it for you. I have both Vectric and CC pro.

You can also try to convert it from DXF to SVG.

Make sure the file name does not have a french accent

I tried the conversion and open the SVG in Carbide. Out of proportion. I emailed the file to William earlier on today and I’ll wait to see his response. My gut tells me Vectric will respond with some excuse that they can’t predict what other software will display.

That being said, SDGuy Anthony, would you mind creating a simple file in your Vectric software and post it here? Perhaps something simple like a rectangle 14" x 31" (that’s the effective cut area of my Shapeoko 3), and 2 circles inside the rectangle 12" diameter? I’ll open in my current version (CC free) and see how it translates. I should be seeing 3 separate objects.

Thanks, Scott

Can you share the DXF here? Or PM.
If it doesn’t have units specified, there is no way to determine the units and any other software must make assumptions.

EDIT: I tried explicitly defining the units of the DXF using the $INSUNITS setting, but Create still imported in mm.
I then experimented with a couple of Autodesk programs (then just used their web viewer):
Using the original DXF with no units defined imported in inches.
Using the modified DXF with $INSUNITS defined as inches imported in inches.
Using the modified DXF with $INSUNITS defined as millimeter imported in millimeters.

All three imported in Create as millimeters. This seems like an issue?


I just made the files as requested.
The SVG file was perfect, but the DXF file is very small.
14 x 31 rectangle with 2 cirlces 6 radius.zip (13.4 KB)

In Vectric, the square is 14 x 31. I exported the Vectors as both DXF and SVG files.
I then imported them each into CC Pro. The DXF file translated the square as 1.22" x .55".

The SVG file was correctly imported.

Agree. I noticed this in the past but just resolved to scale inch data up. It looks like CC just assumes all DXF data is in mm. Which is OK, and arbitrary if the file has no units. It would be nice if CC would read the units & import accordingly, but it’s really quick to scale the data as well. Either Scale: 25.4 or set the width or height to the desired known value.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.