Vcarve Clean up out of alignment

I have the Shapeoko 3 XL and I have a strange thing happening with my VCarve. I have it set up to do a first cut and then a second for clean up. I’m keeping the depth the same, just hoping to clean some fuzzy walls, but the second path is out of alignment from the first.

I’ve tried putting both cuts in the same file and also just running a single cut file twice and both result in the same thing. Parts of the cut are 1/8 off of the first cut, other parts are almost 1/2 inch.

Any suggestions would be a big help.

Chuck

Post the file and a photo of your result?

Are the offsets between the first and second cut along the X axis only, Y axis only, or a bit of both ?

Just the X Axis. I’ve done this before with contour and pockets and it works perfect.

See attached for a picture.

1 Like

Here is the file I used. Single pass, run twice. Alhum - 8x5.5 - center.nc (49.3 KB)

Here is a picture of when I ran it with two passes in the same file. (Sorry for the multi posts. It didn’t let me post more than one file in a single post)

The Gcode is clean, so this is either:

  • a loose pulley on the X motor (my guess)
  • steps lost in the X axis due to a collision in between the two run

Did you recheck your zero between the two runs ?
If the zero was still in the right location just before starting the second run, it’s probably the X pulley
If the zero is already off right after completing the first run, then it’s lost steps due to something happening during the first run (unlikely, since it seems to complete correctly)

One thing I do to detect pulley slippage is drawing a line with a marker across the pulley and motor shaft:

If the pulley slips on the shaft, it will be immediately visible.

First things first, inspect the setscrews on the X motor pulley: one of them should be aligned to the flat on the motor shaft, and both should be nice and tight.

4 Likes

Fixed! Thank you thank you.

The X-Axis motor was aligned to the flat and tight, but the two Y-Axis were both off and loose. Took all the motors off and aligned, tightened and reinstalled. Ran a test of that same file and there was no offset.

I’ll keep an eye of those motors and check for slipping for the next batch of runs.

Appreciate the help!

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.