VFD Ignoring PWM input

Kinda stuck on this. I can run the spindle just fine when I set up the VFD in manual mode using the pot on the controller or the up/down arrows. When I set up the controller for using control inputs from the Carbide motion v 2.4e control board, I can’t get the spindle to run.

Here are some specifics:
Huanyang HY01D511B, 110V controller with the setting per Julian’s excellent instructions
1.5 kW Huanyang spindle
Carbide motion v 2.4e control board

Here is what I know:
Spindle runs fine when VFD is set up to control from the pot and I get 24,000 rpm at max speed as measured with a digital tach so my wiring from the VFD to the spindle is correct.
PWM output 0-5V is confirmed with my trusty old Fluke voltmeter.
Jumper is set to VI when I use the PWM

Here is a pic of my wiring:
PWM + to VI
PWM ground to ACM
DCM shorted to FOR

I have triple checked the VFD parameters and they match Julian’s with the exception of the change to 110v for my setup.

Any ideas???

A bit more info. The PWM output from the board was confirmed using M3S1000 and M3S24000 through the command line in UGS and measuring across the VI and ACM on the VFD with the meter.

The wiring looks ok and the PWM measurement rules out something on the Shapeoko side. You must be close.

I guess you already double-checked that VFD params are still what you think they are ? (there have been some cases where for some obscure reasons, the VFD has reset the values to factory defaults).

When the VFD is configured for PWM input (PD001=1 and PD002=1), does the speed pot still do anything ? If not, I would maybe take a wild guess that it does take PWM as an input but the parameters mapping the VI voltage to given RPM values are incorrect ?

Other than that, the only thing I could recommend as a last resort is a reset to factory settings of the VFD, then re-apply all parameters. Extremely tedious, but it’s also quite easy to change one parameter “for a test” and forgetting about it later (don’t ask me how I know)

Julien, I checked the VFD parameters and they were all ok and I made sure that the pot worked properly as well.

Next, I did a VFD factory reset and reprogrammed the parameters and like magic everything works fine now.

Thanks for the help!

Tom

1 Like

Happy to hear it worked, it’s at least the second time I have seen this reported, so I will recommend it upfront next time this comes up :slight_smile:

Do they (you) recommend cycling the power after changing any parameters to make them active?
Just a thought.
Cheers
Mike

Interesting thought, out of curiosity I went back to check the user manual, but there does not appear to be any explicit statement about having to power cycle for params to be taken into account. But it is quite possibly a reason.

I checked that and it did not seem to make a difference