Vfd spindle dead?

A few days ago I went to the shop and turned the Shapeoko on and everything was good until the spindle didn’t spin up. I stood there in dismay as I watched it push into the board before I paused it and stopped it. Tried everything from the start again and the same thing (except I stopped it and inch from the wood). Any thoughts as to what might be going on? I did go to MDI and tried to see if the spindle would spin up. Put the command in and it said BUSY and then nothing. I unplugged everything and plugged back in, tried and the same symptoms. I saw there was an update to Carbide Motion so I uninstalled and reinstalled on the laptop. Tried again and same thing, no spindle. I tried calling in but nobody would answer. Maybe because of the Holidays? I was hoping to get a project done by now. Any thoughts on what to do next.

Let us know at support@carbide3d.com

While you’re waiting you could put a Carbide Compact Router or Makita RT0701 back in.

I’ve seen a intermittent connection at the harness connector to the Shapeoko PCB. Send a M3S18000 in the MDI screen and wiggle the wires at that connector. Could be a clue as whats happening.

1 Like

I bought it with the upgrade VFD so I don’t have another router.

I’ll look closer at that connection today. I unplugged and plugged everything back in but that doesn’t mean there couldn’t be a loose connection. I sent the M3S10000 in the MDI screen but didn’t wiggle wires at the same time. I’m crossing my fingers that it’s something that simple. Just got the CNC over a month ago and it’s worked flawlessly but with vibration something could have worked loose. I’ll post back what I find.

Was out in the shop and tried a few things but to no avail. It’s got to be something easy. Something with the VFD that I’m not seeing. Held down the jog button and the spindle would spin while holding down so that’s good news?!?

What’s your $32 setting?

$32 setting? What’s that? I guess I’ve got some homework to do. When I bought the VFD with the Shapeoko Pro and I had to call in when I started it up and had issues with it not moving to the bit setter I had asked the tech about the VFD and he said I would never have to worry about it. So far I have never had to do anything with it. It’s just mounted under the table out of sight.

Sorry…I was posting quickly and could’ve explained my thinking.
Grbl, the firmware running on the Shapeoko controller / Carbide 3D pcb, has a series of user configurable settings. Each setting has the $ prefix. The $32 setting is either 0 or 1. This setting either diables (0, default) or enables (1) laser mode. When Laser Mode is enabled, the signal for the spindle/laser is only sent when the machine is in motion. Based on your last comment of the spindle working while moving only, I thought an easy thing to check would be that $32 setting (should be 0 unless using a laser).


I checked the $32 setting and it’s a 0 (default).

Hate to even ask but your lockout button on the VFD is lit up, yes?

1 Like

Yes, the red button is lit up when running the CNC.

Looking like the VFD controller box has issues. I’ll have to send it in for repair. Only two months old now. It was good while it lasted anyway. I’ll have to buy a router to use as a backup in the meantime.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.