X axis jumps during cut

I’ve been dealing with an issue on my Pro XXL. My cuts on the X axis are getting shifted. Sometimes by a little and sometimes by a lot.

When I move the machine around with the rapid jog function it seems to move smoothly. But during the cut I notice a couple times it hesitates then resumes.

After oiling the machine yesterday, my first cut was shifted by 8mm.

I think the bearings on the x rail are getting stuck at times. I’ve found this thread on oiling the rails.

I’ve also found this video on YouTube that I tried. I would even add, that I’ve used more oil than the video suggested. However I have been using compressed air to blow off the machine for some time. So I’m thinking I may have more build up in the bearings than the oil can clean.

Am I going in the right direction or are there other failures I also need to figure?
I will try and get a video of it occurring. Any advice is greatly appreciated.

I just ran a test piece of mdf and it went smoothly.

The video is 10 minutes of it running as expected.

I did see the rail have some slight debris so I cleaned it up and added a little more oil.

Now I’m wondering if it has something to do with my bit and the material I’m cutting. Like the hard wood and acrylic is hard enough and my bit May no longer be sharp enough? Or if it just took some deep cleaning and working it back and forth to finally get it right. :man_shrugging:t2:

Now I am pretty confident my issue is a dull bit. :flushed:

I ran a test piece on some scrap acrylic and ran into my X axis jump.

Feeds and speeds have to match the material and tool.

One thing which will help, is to reduce tooling engagement — cut as a pocket and avoid slotting.

1 Like

I have been using the defaults from Create. For acrylic is has always worked fine, but I guess I need to start slowing the feeds down as the tool wears?

I have not grasped the rule of thumb with speeds & feeds. Like when to speed up or slow down each. Any advice there? Or links to something I can read up on?


1 Like
  • disconnect the belt and move in x to see if binding.
  • in oak with a 1/4 bit I use .045 depth of cut 45 ipm 13000 rpm
  • with my pro I chased this problem for a long time. Finally replaced the x motor works fine now. $45
1 Like

oh boy! thats going to be some reading; I will need to get a note book out for that lesson. Thank you for the information Will!

Check to see if you have a pulley slipping a bit on the stepper. One sure it is sound put a line on the pulley as a witness mark to verify at a glance.


Good luck


Ah that is a good idea. Thank you.

Well I thought oiling the rails and adjusting my speeds and feeds was my issues. But I am not done with this problem yet. The x axis jump is random. I need to try both Zman and Godtar advice and see if that works. I hate that it’s happens after an 8 hour engraving.

I think I have the problem resolved.
I found that the set screws on the x motor had come loose and slipping. I was so frustrated at the time I didn’t think of taking pictures until after I got it back together.

I had noticed when removing a bit in the spindle it moved to the right when I was loosing the chuck. Then I just moved the head back and forth a little bit easy then it would get hard again. So i took the stepper motor off and with some pliers holding the center drive of the stepper motor I could wiggle the gear back and forth.

Now put a witness mark on it so all you have to do is a one-second check.



This topic was automatically closed after 30 days. New replies are no longer allowed.