X limit switch error blue light is on


i am trying to get in touch with carbide to help me but bno luck so far. i thought i would reach out here to see if my assumptions are right.

i just put together my 4 xxl and everything went fine. now that i want to do my first homing it keeps giving me a x limit error.

if i try to home all axis home except for the x axis. the blue light on the control board is on and wont go off.

i tried to put the y limit switch on the x port and it does not give me any blue light. and when i run the homing button without the x switch connected it will go but of course run into the stops.

am i right to say that thwe problem is the limit switch or wires of the limit switch?

the limit switch does give me a red light when i flash metal in front of it.

thank you!

Sounds like it might be a bad switch — please let us know about this at support@carbide3d.com and we will do our best to assist.

Wanted to following say the problem is resolved. Carbide did an awesome job helping and got me up and running. ( it’s was a backwards cable). They also overnighted me a new cable so I don’t have to Plug it in backwards anymore.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.