XXL "Limit Switch Hit" at 425mm

Recently purchased a XXL and after homing I cannot jog it past 425mm in the x axis and 457 mm in the y axis, it gives the error “Limit Switch Hit” yet I am no where near the limit switch. Anyone else have this problem? Solutions?

Please configure soft limits per http://docs.carbide3d.com/shapeoko-faq/shapeoko-enable-homing/

I did that, value of true and 850 and 850

Please check the values for

$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=80.000 (z max travel, mm)

(those are the defaults listed at: http://docs.carbide3d.com/software-faq/shapeoko-3-default-grbl-settings/ — but they may need to be adjusted on an XL or XXL if soft limits are enabled, $20=0 (soft limits, bool) would disable them)

If that doesn’t resolve it, post the details of:

  • CM version
  • CM preferences (screen grab?)
  • Grbl defaults (open the Log window, open the MDI and send $$ to the machine and copy them out of that)
1 Like

Thanks I just disabled them for now. Worked like a charm

1 Like