Y Axis Slipping?

Greetings.
I received help from the forum with homing errors last week and here I am again!
I haven’t talked to support but will depending on the results I get from the community.

I’ve tried a simple project, a hexagon with text (Ted) inside outline with a pocket. The first couple times I tried to cut it in plywood and it started out well but then seemed to lose track of where it was working and carving over the letters and outside the pocket area it had been working in. I moved to some MDF and tightened my Y axis belts a bit and tried again. Same error. Did some research and saw mention of making sure the pulleys were tight on the servos. I checked them out and while I could tighten them up they certainly weren’t loose. Another run while I sat and watched through about 40 minutes when the letters started to break off thiner pieces. I was trying to cut the pockets to a depth of 0.3 inch so I backed off to 0.225 and tried again. I wandered off a bit and came back to another case of the Y axis looking skewed.

I paused the run, recorded the X, Y and Z positions and setup a stack of a couple pieces of wood, with tape and a mark for where the bit was at those settings. Stopping the job causes the spindle to initialize back to SW limits. I then returned it to the X Y and Z that I recorded and took the attached picture, where you can see that the Y is off from the setting in the previous job which would account for the errors in the carvings I’ve been seeing.

I have my belts very tight and the pulleys cranked down about as far as I dare.

Suggestions appreciated.
Ted


Error

(Y) steps were lost somehow, and that’s unusual (usually it’s X and its pulley set screws)
Is it possible that while moving up and down, something (tool/gantry/dust shoe) collided with something else (hard limit, top clamp, …) ?
At the 40 minutes mark when things started to go wrong, did you notice anything peculiar or did it start tp shift out of the blue?

1 Like

Thanks for the response, Julien. There wasn’t anything that it could have collided with. I wasn’t watching the machine when it got off track so I don’t know if there was an outside stimulus but I’m pretty sure there wasn’t, The one time I did sit there it didn’t slip.

Ted

Follow up to this post.
I contacted Carbide3d Support and they recommended a video chat. We were able to get a time this past Friday and I really nice gentleman by the name of Flemming walked me through debugging the problem. He appeared very knowledgable and we were successfully able to diagnose the problem to a bad connector on my Y-Right stepper motor. I managed to get it to work on Saturday and had a fun weekend getting everything calibrated. Carbide 3d will be sending a new cable to replace this one in case my “fix” doesn’t hold up.

Thanks again!
Ted

4 Likes

I like when it ends well.