Z and y axis not working properly for Hello World

There is no scroll bar on the log page

Type $$ (Enter) and there should be a scroll.

See Photo

Here is what I do
turn on Shapeoko3
open carbide motion
click mdi tab
Type $$ enter or send done both
click settings
click log

All I get is the received message count and the Mpos line. There is no scrool bar

Your screen is different to mine


The first thing you do after opening Carbide Motion

Click Settings,
Click Log
Click MDI

Type $$ (Send/Enter)

Test Waiting…
___________$$ ___________
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=4 (dir port invert mask:00000100)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=40.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=5000.000 (z max rate, mm/min)
$120=400.000 (x accel, mm/sec^2)
$121=400.000 (y accel, mm/sec^2)
$122=400.000 (z accel, mm/sec^2)
$130=425.000 (x max travel, mm)
$131=465.000 (y max travel, mm)
$132=80.000 (z max travel, mm)
___________N0 G4P0.05 ___________
___________$# ___________
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]


Ok as I said before, your machine had a $3=6, right?

Y Reverse
Z Reverse

DO you know WHY or HOW this setting got in there? (I know I’ve asked this 3 times now)

It ships from the factory $3 = 000000000

So to FIX the Z (Since it was already reversed, you need to UN-Reverse it so to bring it BACK to factory by typing:


I do not know how the $3=6 was there.
All I have entered was #3=4 by mistake and then after you corrected me I entered $3=4, nothing else. I will change it to $3=0 and let you know.

Yes success Thank you very much Rich. Now to set my homing switches. is this right

Yes that is my recommendation, but many people only use $22=1 (Homing). Your choice.

Thx again I will be like the most and just use $22=1

I just received my Shapeoko 3 a few days ago and had the exact same issue. Grbl showed that $3=6 but z and I were operating backwards. I tried entering $3=0 several times to reverse them but it seemed like it didn’t change the setting. Eventually it took and with $3=0 they were still reversed. I changed it back to $3=6 and now the directions are correct! I don’t know why it didn’t work when $3=6 in the first place???
Then I tried drawing the Shapeoko 3 “Hello world” but it took several minutes to draw the first “S”. It was as if it paused for several seconds after every line segment of the “S”. Did you have this problem as well?
I sent something into support several days ago about the slow operation but I haven’t heard anything back yet.

Hi Brian
Once I finally got my y and z axis working properly my Hello World test printed properly with no pausing, I hope you get that working soon, I don’t know much about the SO3 to help sorry. I have printed 1 sign to see if I am doing everything right and it came out ok for a first try. I had to bump up the speed on the feed and plunge, the settings on Carbide Create were way too slow, I went with 75 ft/min on the feed and 37.5 ft/min on the plunge. Here are the files I created, I used a 1/2" 90 deg V bit, you can try it if you like to see if it works. Good Luck

.Wine Question.c2d (5.6 KB)

Wine Question.egc (1.6 KB)