Z Axis didn't retract half way through job

So I was trying to hollow out a guitar body today. As the machine was going to make it’s last pass for the pocket, it tore through the side wall instead of retracting to the normal hight as it did on all the other passes. After that, it drilled straight down through the material and into the wasteboard at the location I would have expected it to start the next pass.

I am assuming it’s something to do with my Z axis but I didn’t hear any belt slipping, and the endmrill is still tight in the machine. any ideas when why it wouldn’t have retracted properly?

I am assuming this is something mechanical but I’ve attached the gcode in case someone can see something in there.

guitar body 4E.nc (1.0 MB)

it could be the set screw on the Z axis as well… they’re tiny m3 thingies

1 Like

I can’t tell if it’s loose or not because the head seems to be stripped already. I’ll work through trying to check all the components of the Z carriage in the morning.

Thanks for the suggestion.

Replace those with M3 socket head cap screws when you remove them.

1 Like

Is there thread locker on those screws from the factory? I may have to drill them out.

they don’t; have heads they are hollow and fit a tiny hex (m2/m3)
sort of like these: https://www.ebay.com/i/223234603149

1 Like

I tried the hex keys that came with the machine, none seemed to fit well enough to turn the set screw.

Should be a 1.5mm hex key. They’re not hard to strip, but I never had issues with mine.

1 Like

I had to drlll some out because they were damaged. It only took a couple of minutes but I re-tapped with larger screws that are easier to tighten and have a larger base to grip the motor shaft.


I finally got around to trying the project again. I cleaned the machine up, verified all the v-wheels, set screws and belt tension was set properly. Cleaned out the collet, tightened up the .25 EM and ran the program again using the same gCode. I was pretty sure this was a mechanical issue so didn’t think I needed to recreate the gCode. Wouldn’t you know, same problem, same position / depth. So now my question is, how do I go about looking into the gCode to see where the issue is? I know it occurred around 45 minutes into the project. Is there anything I can do in Carbide Create that may show me the path that is causing this? Picture below for reference. the first attempt is in the front, second attempt still on the machine.

Guitar gCode Issue

That’s too bad, did you check that your Z is still set properly? Did you run your job in CAMotics to visualize the toolpaths? Is your retract height set properly? Do you know the GCode line where it happened so it can be examined to see if there is something there?

1 Like

Retract height is set fine, it worked for all the other passes while carving out the pocket. I have not used CAMotics before, I will look into that to see if it shows me anything.

as for the gCode, I didn’t see what line it was at while rushing to stop the job. I only know that it happened about 45 minutes into the project.

Is there a log in carbide motion that would show where it stopped? I had to power down the machine before it bored down through the material again.

The ability to get something in CM that says last line processed was line XXX has been something requested from Carbide but no luck so far. Re: retract height, I was curious if something would have appeared in the GCode to change the retract height mid job.

I was hoping to review the gCode for some sort of explanation as well but I didn’t know the best way to go about it. I think I will have a look at the simulation and see if it shows the path going through the side of the project. at least that way I would know the issue is either in my design, or in the gCode generation.

If you are at all interested in seeing what the paths look like for yourself in CAMotics, I attached the gCode in a previous post above,

Looked at it in CAMotics and there is no damage to material but there is a rapid positioning that seems to be in line with the damage to the material. Maybe increase the safe retract height.

1 Like

Mike, I had the same thing happen to me last week while pocketing out a pretty deep jewelry box. It ruined a pretty nice chuck of walnut that I had layered up and also made a deep cut in my wasteboard before I could hit the panic button.:open_mouth: Still don’t know what the issue was. It could have been a belt slip–and that’s what I attributed it to, but I re-generated the G-code and ran the job on a new piece and everything went well–kept my finger on the pause button the whole job, however.

It does appear that z-axis belt slippage is not uncommon. With the SO3, there are “helper springs” to assist in lifting the carriage, and on deep cuts, I have found it does not take much to “hang up” a little when the bit is lifted out and you end up with a z-axis that is out of alignment with original zero for the next pass. Sometimes I’ve found it necessary to “ride the throttle,” so to speak, when cuts get to the deeper parts (I slow my feed rate to take some of the stress off the bit).

Another thing I routinely do–and I am no g-code expert–is look at the tool path extents when I first load my jobs–particularly the Z axis codes. It’s pretty easy to calculate if the bottom of the Z looks to be way out of wack. That, and when I’m gonna pocket out an expensive mahogany body blank, I run a test of the whole set of cut files on a glued up softwood (usually 2X6s) blank before running the files on the expensive stuff.

Line 23842 (possibly, depending on depth) is the retract move that fails. It is the last retract move that then goes across that area. No reason in the gcode for it to fail.
You could try changing that line from G0Z5.080 to G1Z5.080F300
That will do the retract slowly instead of at your max feed for the Z.

Since I don’t know the depth at that point, you could try replacing all of your Z retracts, or, easier change your Z maximum rate to something like 300 or 400. Send $112 = 400 through the MDI.

If that doesn’t work, you could try moving the endmill off of the “wall” before you retract.

These are band-aid fixes to get the carve complete.

1 Like

This is all great information. Thank you. I didn’t think it was that deep of a pocket, the max depth for this pocket was 1 inch i believe. Should I be tightening the belt on the Z axis?

I still think that it is strange that the issue occurred at the same location and same depth both times.

I will try to adjust the maximum Z feed rate and see if that helps.

How would I do this?

Thanks for all the great input.

I’m having a very similar problem, with the z axis not properly retracting. Then it traverses and plunges both the intended amount plus the retract distance, putting the bit way too deep. Lost several parts now and getting super frustrated.

Based on my Facebook post of the problem, this isn’t a super rare issue.

Please contact us at support@carbide3d.com and we’ll do our best to work through this with you.