Z-axis losing zero on Shapeoko XL

I’ve seen posts of people’s cutters diving too deep but mine is doing the opposite. One the second tool path the cutter will begin its path about a half inch above the material. Just cutting away in midair even though the first tool path seemed fine. I can stop the program, send the cutter to zero + 6mm and all seems fine. Restart and same issue. It doesn’t always happen though.

Specs, scenarios and pics below.

Brand new XL with Z-plus and BitSetter
Latest versions of CC and CM
I zero the machine manually using a piece of paper to set Z.

Occurrence 1, first tool path started properly but never went through the material as expected. It stopped about .25 inch too shallow. Second tool path began and was routing above the work piece in midair. I stopped and zeroed and all looked fine. I modified the CC file to remove the first tool path and loaded in CM. Double checked zero, ran it again which would only run the second tool path and saw the same issue, cutting in midair. There was no tool change in this job.

Occurrence 2, VCarve inlay using advanced vcarve tool path. The cavity job ran great without issue (walnut image). The inverse seemed to run the bulk removal part just fine. Tool change to vbit and again it started cutting in midair. I let the job fully complete and checked zero and it looked just fine. Cutter was 6mm above the surface as expected. This job had a tool change since it’s an advanced vcarve but it was all one tool path.

Thankfully both of these were test runs so nothing was ruined. Any ideas? It’s not the end mill slipping up into the collet. I’ve triple checked all depths and material thickness in CC. The material is not moving around. The material is thin so I am not maxing out the Z on path/tool changes.


Can you share the gcode that resulted in the depth issue?

1 Like

logo.nc (912.6 KB) runway2.nc (106.1 KB)

Just ran the vcarve again and had the same issue. The only difference is that the machine was fully power cycled since that last attempt. I turned it on, initialized, double checked zero, loaded the gcode and ran it. The bulk removal works perfectly but after the bit change the Z shifts up for some reason.

In the image you can see that the depth of the first cut is well within the tolerances of my harbor freight calipers at 0.2 inches. After the tool change the vbit rides above the work piece and barely touches it at the end of the run.

Here are two reference videos as well. One shows that CM thinks the bit is at -0.20 while it is actually not even close. The other video shows after running the job setting the cutter back to Z zero+6mm and it looks spot on.



Problem solved! I’m a moron. The lowest point in my tool paths were below the full Z travel of the cutter head. I guess I need to add a second waste board to raise up the work pieces.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.