Z-Axis Malfunctioning Shapeoko 3XXL

I recently(10 days ago) replaced my board b/c of a bad stepper driver, since then I ran a few projects and it was for the most part OK although I wasn’t getting feedback to CM as to the current position of the machine and for some reason jogging the z-axis after zeroing it would throw it into a homing cycle. My big problem occurred yesterday after finishing a program I loaded another, repositioned the cutter to current XY and tried to jog my z when it started to vibrate violently similar to when there is an obstruction. I checked for an obstruction and tried to retract the z axis and got the same vibration. I turned off the machine and manually moved the z to check for any obstruction and found none. I powered everything back up, attempted to initialize and same problem it vibrates violently and moves up and down 2-3 inches at the same time time before throwing an error in CM of “GRBL ALARM 9” and failure to home.
Here are my settings:
Machine: Shapeoko
GRBL Version: 1.1f

Carbide Motion 618
Machine Controller State: INIT
Grbl Cycle: Idle

{
“bitRunnerEnabled”: false,
“bitSetterEnabled”: false,
“bitSetterX”: 0.0,
“bitSetterY”: 0.0,
“bitZeroType”: 2,
“connection”: 1,
“lastConfigSent”: 0,
“lastProbeIndex”: 0,
“lastSizeOption”: 0,
“odometer”: [
{
“cleared”: true,
“minutes”: 0.5117666666666671,
“startDate”: “2023-12-12”,
“travelX”: 1868.325011253357,
“travelY”: 2112.27499294281,
“travelZ”: 132.0
},
{
“cleared”: true,
“minutes”: 0.0,
“startDate”: “2023-12-22”,
“travelX”: 0.0,
“travelY”: 0.0,
“travelZ”: 0.0
},
{
“cleared”: false,
“minutes”: 0.0,
“startDate”: “2023-12-22”,
“travelX”: 0.0,
“travelY”: 0.0,
“travelZ”: 93.0
}
],
“showCarbideRouterRpm”: true,
“spindleType”: 0,
“travelX”: -830.0,
“travelY”: -850.0,
“travelZ”: -100.0,
“version”: 0,
“workOffsetX”: 0.0,
“workOffsetY”: 0.0,
“workOffsetZ”: 0.0
}

0 = 10, Step pulse, microseconds
1 = 255, Step idle delay, milliseconds
2 = 0, Step port invert, mask
3 = 6, Direction port invert, mask
4 = 0, Step enable invert, boolean
5 = 0, Limit pins invert, boolean
6 = 0, Probe pin invert, boolean
10 = 255, Status report, mask
11 = 0.02, Junction deviation, millimeters
12 = 0.01, Arc tolerance, millimeters
13 = 0, Report inches, boolean
20 = 0, Soft limits, boolean
21 = 0, Hard limits, boolean
22 = 1, Homing cycle, boolean
23 = 0, Homing dir invert, mask
24 = 100, Homing feed, mm/min
25 = 2000, Homing seek, mm/min
26 = 25, Homing debounce, milliseconds
27 = 3, Homing pull-off, millimeters
30 = 24000, Max spindle speed, RPM
31 = 0, Min spindle speed, RPM
32 = 0, Laser mode, boolean
100 = 40, X steps/mm
101 = 40, Y steps/mm
102 = 40, Z steps/mm
110 = 10000, X Max rate, mm/min
111 = 10000, Y Max rate, mm/min
112 = 5000, Z Max rate, mm/min
120 = 500, X Acceleration, mm/sec^2
121 = 500, Y Acceleration, mm/sec^2
122 = 400, Z Acceleration, mm/sec^2
130 = 845, X Max travel, millimeters
131 = 850, Y Max travel, millimeters
132 = 100, Z Max travel, millimeters

Maintenance:

Travel (km) 0.00, 0.00, 0.00, 0.00 Hours since 2023-12-22
Travel (km) 0.00, 0.00, 0.00, 0.00 Hours since 2023-12-22
Travel (km) 0.00, 0.00, 0.00, 0.01 Hours since 2023-12-12

Queue Empty

Any ideas???

You are configures for a belt-drive Z-axis — which Z-axis does your machine have?

I have a belt driven z

For a belt-driven Z-axis, things to check:

  • belt tension
  • eccentric nut/V-wheel adjustment
  • feeds and speeds

I already took stepper off belt, the vibration is occurring with no tension. I also switched it with x axis motor and it vibrates the same way, so not the motor

Send a video to support@carbide3d.com

This topic was automatically closed after 30 days. New replies are no longer allowed.