Z-Axis moving 4 time the desired distance

Everything was working fine and I just finished a cut and when I went to start the next batch of gcode the z-axis was moving 4 time the required distance. I moved the motor to the X-Axis and it moves the correct distance but when wired to the z-axis it’s moving 1" instead of the required 1/4".

Note that I am moving it manually.

I can change the steps/mm to 10 and get back to the correct distance but that seems odd.

Any thoughts? Motor driver IC blow a coil driver?

There is a function called micro-stepping which allows the machine to move / hold position in smaller increments — this is enabled by default / built into the Carbide Motion boards — it would seem that this has gotten disabled on your board — please contact support@carbide3d.com

Thanks for the quick reply but I am running a stepoko board which has dip switches to set the step rate. I checked these and actually tried different settings to make sure the switches were working properly. When I change the step rate the from 1/8 to 1/2 the amount of movement changes accordingly so that part seems to be good.

If the driver chip was blown then it wouldn’t move or be really jerky but that isn’t happening, it’s just moving 4x the desired distance. I can change the steps/mm to 10 from 40 and the distance is correct but not sure that resolution will be good enough for what I am doing.

Very strange issue and I am lost at this point.

Thanks again

Please contact Sparkfun support — no experience here with them and obviously failed to consider that.

Just so if anyone else runs into this or other strange behavior, the board has appears to be damaged from ESD. It’s winter here in Minnesota so there is no humidity at all in any heated location so one of the driver chips (Z-Axis) took a jolt and started to move 4x the required distance. Very strange failure but a new board has fixed the problem and will keep a spare just in case.

I ran ground wires from all the rails to earth ground to help prevent this in the future and I have probably close to 20 hours of run time without issue so I am hoping that grounding everything possible will prevent future issues.

1 Like