Z axis not holding...slipping:(

Hey guys. Need a little help solving a problem.

I am having issues with my Z travel with my Shapeoko XXL with HDZ. Every time I try to cut a hole, it always stops about .150" before the desired cut. I zero X Y Z axis as usual, using Fusion 360 and doubled checked everything there, all good. I set it to pocket a .500” hole depth with -.0125 so it cuts through. It never makes it. Checked spindle, no slippage. When I go back and check X Y Z everything is fine except I notice that Z zero is off. Is it possible that the HDZ is slipping? Bad switch?


Edit. Checked coupler, could barely get a 1/4 turn in, so that seems fine.

Have you double checked your setting for Z steps/mm (it’s Grbl setting $102)? You can verify it by commanding the machine to travel some Z distance and then measuring the actual distance traveled and comparing it to the distance you commanded it to travel.

Hey Uriah, thanks for reaching out.

Yes, put a dial indicator on the Z axis, 100mm = 100mm, but, when I go all the way to the top of Z axis and back down, zero is not where is supposed to be, very strange. Bad stepper motor?

Not likely.
Can you get a video of the:
set zero, jog up, jog back down, and zero is off behavior?

Please make sure that you have configured for an HDZ, not a Z-Plus Z-axis.

If that’s not it, what sort of dust shoe are you using? If the Sweepy, make sure the bristles aren’t preventing it from moving down. If something else, check for mechanical interference.

If you still have difficulties, post your .c2d file, generated G-Code, and step-by-step notes on how you are securing your stock and setting zero relative to it.

What’re they making those bristles out of?!

1 Like

A stiff plastic which since it is so short has quite a bit of resistance.

Hopefully the accessory dust feet with various bristle lengths will be available presently.


something so strong that when my HDZ tried to push down the whole router deflected by a 15 degree angle with very ungood results to the work piece… :wink:

1 Like

Yes, config is HDZ. No sweepy,

I think the problem is coming from when I run CM and it homes to the top of the Z axis and when it comes back back down to stock, it doesn’t hold the settings.

.nc file 4001.nc (13.0 KB)

Something else weird happened, kinda scary. When I hit the Z jog up, it actually went down once :scream: The only saving grace was in was in a hole and didn’t break off end mill!

Test this a bunch. That sounds like a loose connection on the Z stepper, or, hopefully not, a broken wire.

1 Like

So after lots of more tests, still haven’t resolved the problem:( If anything its consistent. In CM, I set 0 for XYZ. I think the problem is when I hit Run, the HDZ goes to the top of the carriage and somehow its not going where it is suppose to, so when it returns to machine material, its off. After its completed the job, I go back to check zero and its off. The question is why?

which retract height are you using in the projet where you notice this ?
EDIT: or to be clearer, does the HDZ collide on top upon the initial retract?


I’m with Julien, when I’ve had any issue like this in the past and it hasn’t been mechanical, then it’s either been that retract height was changed and caused the machine to hit the z axis limit switch during the job, which in turn reminds you quickly to stay near your machine, or my z axis limit switch failed.

Sorry gents, fairly new to this, well CNC anyways:)

It does its “homing” thing when I hit run, it goes to top of Z axis and then returns to machine. Don’t think its a retract high, I think its something with homing switch. When I initialize the machine, Z goes to the top and touches the home switch, but when I run the program, Z doesn’t go all the way to touch switch, is this normal?

Just to clarify on the wording:

  • “homing” (only) refers to the machine going to the back right corner and contacting with all three (X/Y/Z) - switches.
  • during homing / machine initialization, if there is a problem with the Z switch, the machine will tell you (you would get an error in CM “failed to find limit switch”). But you don’t, so your switch is fine
  • later when you hit run, there is no homing, but usually the first move in the generated toolpath (at least when generated from CC) is a retract move, that will raise the Z by a certain amount (specified in the “retract height” in the design)
  • BUT, at this point, there is no more checking/management by the machine whether you hit the top Z switch or not (long story, for another day)
  • so if the combination of your wasteboard height, stock height, endmill length, how high your router sits in its mount, and retract height are such that upon the initial retract, it wants to travel upwards by more than the mechanical travel left on the axis, the HDZ will collide at the top, the switch will be ignored, the motor will skip steps, and from there on the Z axis lost its reference and will not cut the correct depth anymore.
  • but apparently, this is not what happens, since you mention that when you run, the Z doesn’t go all the way to touch the switch (which is the normal situation indeed)

Are you positive that during the initial retract, the Z does not contact on top ?
Can you share a picture of your setup and the associated design file you used, where you had the issue ?

1 Like

Thanks Julien. Yes, thats what I thought, homing was just the initialization of XYZ. No errors when it initializes. Funny as I don’t remember Z always going to the top. It would normally go where the retract height was set in CC. I have a friend helping with Fusion 360 and thats when I first noticed it. Created something is CC and it did the same thing. Here’s a vid so you can see. I hit start, goes to top, waits for confirmation on tool bit, then goes down. (FYI, I hit the stop so it would not hit material) Retract height set to 5mm.


Can you please double-check the following in CM’s settings page:

  • that you have “HDZ, […]” selected in the Z-axis type menu
  • that BitSetter is not enabled

Also if you could

  • go the Settings, Show Log, then go to MDI tab and type $$ then “send”, and copy/paste the full content of the Log window
  • post the g-code file you are running in this thread.

Then I’m sure we can figure it out.

  • HDZ is selected in settings
  • bitsetter is not enabled

[GC:G0 G54 G17 G21 G90 G94 M5 M9 M56 T0 F0 S0]

G-code:Hole test.c2d (6.0 KB)

1 Like

Thanks, while I’m checking those could you also attach the .nc file ? the one you load in Carbide Motion

Ok, $ values are all good, let’s see that G-code file then.