Z Axis not staying on 0

So I ran into a problem, when cutting projects my Z Axis when Picking up will skip and cause the bit to plunge deeper then what I have for my max cut.

The belt is tight, after it does that I’ll stop the job try to reconnect to my CNC and it’ll attempt to re initialize but it go up to almost the top and the motor will sit there and make about a 1/4th of a turn and click. While it’s doing this the best is not slipping. The machine doesn’t was to initialize. When it finally does it then cant find the limit switch. Any help? It’s a Shapeoko xxl. I’m using Carbide create and motion. It’s not in the Gcode.

Any help would be great.

We have some notes on this at:


If you continue to have difficulty please post a .c2d file, generated G-Code, step-by-step notes on how you are securing your stock and setting zero relative to it, and a photo showing an attempt to cut still secured on the machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.