Z axis not working in middle of a cut file?

So I have an issue.

I bought another 3XL (other one is from 2017 and runs CM V3, works perfect, .9 GRBL) and this one runs V4…

I can’t get it to stay in the Z limits, if I’m cutting a pocket (vcarve pro softare) and say that pocket is 18mm deep, i’ll do 6, 3mm passes. When its cutting the pass thats 15mm deep, at the end of the pass when it does its last pass/clean up (as it does each pass) it wont lift up at all. it just makes the dreaded clunking sound. and then forces the bit through the wood running the file as though it did lift etc. Noise, wasted wood, time etc. I’m worried its going to self destruct!

I have both CNC’s set up exactly the same, use the same files, have 2 PC’s that are exactly the same etc.

why does this happen with the new one. I have done all the usual things, sanded the rails to make sure they are smooth, the wheels are round, I’ve tried 3 different belts, changed springs (that shouldn’t matter as its not retracting, thats the issue)

Basically, the Z axis just decides to no longer retract have way through the cut… The only difference to me is the software, its homes perfectly, cuts the first half of the file perfect, seems to be within the Z limits?

Only thing I can find is the limit I see everywhere is $132=80 and on V4 is preset to $132=100 and from what i can tell, I’m unable to change it. could that be the problem?

I’m totally at a loss and having this working for my Christmas rush is the reason i bought another…

I’m by far an expert at running a CNC, but have at least 1200 hours on my old one, use vcarve pro etc. Any advice would be greatly appreciated.

Thanks and Happy Holidays

I’m definitely in the noob category but thought I would throw out the possibility of a loose set screw because those seem to cause so many erratic problems and you didn’t mention checking it.
@Julien pointed out in another thread the technique of drawing or marking a line across the pulley and shaft to see when the problem occurs if they are still aligned, at least you’ll be able to eliminate another possible cause.

1 Like


Thanks for the response, I do truly appreciated it, but Yes, checked all that, even swapped the motor to the one from my other SXL (I’m lucky to have a full working CNC for parts testing) its super tight and lined up perfect. Adjusted the v wheels so it “feels” the same tightness as the other one. I use an engineering square to make sure its aligned perfect as I do so many repeatable cuts.

I feel like ive checked all the normal stuff, the only thing left for me is the software settings, or something in the GRBL??

I also did the check where you unplug the connection to the motor and that made it perfectly smooth.

Its crazy as it works perfect for about 75% of the cut file then just stops using the Z axis, it also doesn’t matter what cut file I’m making (I make a lot of valet trays for Etsy) and I’ve tried 4 or 5 different products and they all do the same. if it was a set screw wouldn’t it do it at random times.

I have noticed that when i get ready to cut and I set CM to “Zero” it tells me the Z is going to move 39mm. thats perfect, 20mm above for the home position and 19mm pocket. it has more than enough travel as I use 2 pieces of MDF as waste boards…

I will say, if I’m just personalizing something and the cut is only text thats 2mm deep, its perfect, every time as it only has one Z movement for the gcode.

Its driving me nuts trying to figure it out… ha

The Z-axis movement is determined by:

  • G-Code
  • stepper driver — usually this is binary, either it works or it doesn’t
  • pulley — check the set screws
  • belt — check that it’s in good condition
  • belt tension — try for guitar string tight, but careful not to bend the motor shaft
  • the mechanical adjustment / spacing of where the spindle mount is mounted, how low the router is mounted, how long the endmill is and how much it sticks out
  • the resistance of the springs — consider removing one temporarily

Thanks Will, I’ve done all them, spent about 5 hours reading and trying everything on here.

Does it make a difference if $132=100 or $132=80?

Does it think it’s out of parameters?

$132=80.000 (z max travel, mm)

That should only matter if soft limits are enabled, which we recommend against.

Got it on video. I guess the screws are loose, but they are as tight as I can make them, in fact i twisted the 1.5mm allen key tighting them. Any idea if I can get some locally, lowes, grainger, HD etc?


you cant here the clunking in the video as the other CNC is running in the background, but does it look like it skipped? sorry for the bad vid, i was worried it was going to break something.

Use an M3 SHCS. Make sure you tighten on the flat of the motor shaft.


Thanks, I’ll find some of them. Its crazy as I just pulled the front cover off, and it doesn’t even look like it skipped/slipped. I wonder if it did a full rotation and thats why putting a sharpie mark on it, it looked good again?

either way hope this fixes it and I’ll report back once I have replaced the screws.

Try jogging the Z while you hold it. If it’s not that pulley, the motor is skipping steps for some reason.

yeah, it wouldn’t surprise me if this was happening, as it looks like that. I have an upgraded motor coming tomorrow from amazon and actually found some new M3 screws to try in the mean time. either way, looks light progress is being made.

I love these little CNC’s, and am glad its getting sorted.


Latest update. I replaced the screws, made no difference. So I moved the Z axis up and down while holding the pulley and it skipped in my hand, and i can’t hold the pulley on my good CNC tight enough for that to happen, so I’m guessing Motor it is…

New one coming today so hopefully that fixes it. I tried to get the pulley off the motor and switch it with a Y axis motor, but its on so tight I’ll probably have to heat it off…I’m hoping I can just use a heat gun and not the torch, Any advice on doing that on little pieces… I’m more than open to it.

I used a 2 leg puller to get the pulley out. It was a bit big but I was still able to get it off. I do think that the set screws are the problem. I drilled mine out, tapped it and put a larger screw in place. The screw had a larger surface to press on the shaft and larger head to tighten them. Now that I have an HDZ, that is no longer an issue.

1 Like

Still not sure of anything, but i put bigger M3 screws in with a flat bottom and i can hold the set screws/pulley in my fingers and the motor will skip if I manually move the Z axis up and down. That tells me there isn’t a lot of pressure needed to cause the motor to skip (my fingers aren’t that strong), not the belts or pulley/set screws

I could take my old set screws out with a hex key, so that wasn’t a big issue.

who knows, if a new motor doesn’t stop the skipping, not sure what it is.

And I really want a HDZ. hopefully they get more in stock soon.

1 Like

Well nothing has worked, new motor, new files made, gcode etc. it still just wont retract properly when cutting a pocket.

For example, if I set the safe z to 20mm, it might retract 15mm then clunk and not go any further. I have new set screws, new motor etc.

Cutting profiles it has worked every time, only pocket cuts does it fail. If i’m cutting a 18mm deep pocket in 5 steps of 3.4 mm each on the 4th retract to go back to the start and cut the final pass, it just wont go up all the way,

Could it be voltage from the Mother Board. At this stage I have no use for it anymore as Christmas rush is almost over… I’d really like to get a old mother board that runs .9 as my old CNC runs great.

Any new ideas??

How are you generating the gcode?
Have you tried multiple files?

Nothing between the two versions would cause what you’re seeing. You can always flash 0.9 to the board…I wouldn’t, though.
That Z belt should be tight and also recheck the v-wheels. What happens when you home the machine after this?

Can you post your $$ grbl settings?

1 Like

The code is generated from Vcarve pro, same as always, (these same files work perfect on my other CNC) I’ve tried 6 different files I know work as they work on the other machine. I’ve also made new designs and cut them and 1 worked, 1 didn’t.

The one that worked was a small file/design so i didn’t have to wait for ever. (I simply scaled my bigger designs down)

I make valet trays, so pockets are what i cut all day everyday…

What causes the clunk?

Is it hanging up on something mechanically?

(7536): <- ok
(7535): <- $132=100.000
(7534): <- $131=850.000
(7533): <- $130=845.000
(7532): <- $122=400.000
(7531): <- $121=400.000
(7530): <- $120=400.000
(7529): <- $112=5000.000
(7528): <- $111=5000.000
(7527): <- $110=5000.000
(7526): <- $102=40.000
(7525): <- $101=40.000
(7524): <- $100=40.000
(7523): <- $32=0
(7522): <- $31=0
(7521): <- $30=1000
(7520): <- $27=5.000
(7519): <- $26=25
(7518): <- $25=2000.000
(7517): <- $24=100.000
(7516): <- $23=0
(7515): <- $22=1
(7514): <- $21=0
(7513): <- $20=0
(7512): <- $13=0
(7511): <- $12=0.010
(7510): <- $11=0.020
(7509): <- $10=255
(7508): <- $6=0
(7507): <- $5=0
(7506): <- $4=0
(7505): <- $3=6
(7504): <- $2=0
(7503): <- $1=255
(7502): <- $0=10
(7501): -> $$
(7500): -> gc_not_motion