Z- Axis won't stop traveling up after initialing

I have been using my 3 XL with Z-Plus today to cut speaker cabinets. After about 1 hr of cutting I turned it off for 1 hr. I came back and initialized the machine again and this time the Z Axis would not stop trying to hammer itself into the top position. It would make a noise since it reached the end of its travel but still kept trying to move up. So I was not able to initialize it. Then Carbide Motion threw this message " Machine controller restarted unexpectedly and maybe in an undefined state".
I used the wrench trick to see if all the red limit switch lights would come on and they all came on properly. I unplugged and plugged the wire harness connections for the limit switch and Z steeper motor and rebooted my laptop. I tried to initialize the machine again and same thing kept happening.
Has anyone experienced this and how did they solve it?


Check that the homing switches are positioned so that the machine can move so as to activate them.

Also, power up and go to Settings and check that each switch registers as the correct Active Input on the Settings pane.

If there’s nothing obvious to address, let us know at support@carbide3d.com

Hi Will thanks for the quick replay.

I upgraded to Carbide Motion 613, I was using 575 before). Now I see the setting input pin state window. I attached a screen shot of it here. I was not sure if these setting were ok. I was not able to click the circles beside the x y z axis options.

The circles aren’t controls, but status indicators. They will light up if the switches are working properly and metal is presented to them.

Let us know about this at support@carbide3d.com and we will work through this with you.

Also see:


Hi Will. Its all working now! It was the aluminum pipe that was within the Z-Plus axis. It triggers the homing switch. It had loosened over the 3 yrs that I had the machine and was not getting close enough to trigger the switch. I took the Z Plus apart and tightened up the aluminum rod that triggers the Z homing switch. Put it back together and it worked like a charm.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.