Z-belt slipping in cold weather?

Hello forum,

I’ve had my XXL since August or so. Initially I had some Z-belt slippage issues, but finally got it adjusted and have been cutting happily for the last few months, until today… I ran a couple jobs today with zero issue, 1/4" flat endmill, 70ipm, 30ipm plunge and .125" DOC cutting some poplar, making pockets for the most part, full depth 0.750" stock. I have a 1/2" HDPE spoiler board on top of the stock MDF, so when I make full depth I’m still 1/2" shy of the MDF. Bit stickout I would guess is 1.25" or so and the Dewalt is all the way down in the mount. Anyways as the night has progressed I made probably 5-6 good successful runs, until about an hour ago while making a 3/4" circular full depth pocket and on the final cut through pass my Z-axis jumped up. I tried homing and running again and same result. So I adjusted the Z-axis belt a bit tighter, homed the machine and made another run with same result. So I tightened the Z-belt a little more (almost guitar string tight at this point) and made another run, same result. A couple months ago I went through my all of my steppers and ensured that the set screws were on the flats and that they had loctite, so I’m reasonably sure the pulley isn’t slipping. Also tried knocking my feeds down to 60ipm with 25ipm plunge. The only thing peculiar about tonight is that it’s 34F degrees in my garage. I don’t want to tighten the belt any more for fear that I’ll bend something, it’s about as tight as I feel comfortable with already. Has anyone else had this experience, specifically with running an SO3 at near freezing temperature? Any suggestions? Haven’t looked yet, but maybe my belt shed a tooth in the cold (I think they’re rated below freezing, and it’s jumping probably 1/8-1/4" so it would probably be several teeth)? Really liking my XXL, but this Z-axis belt thing seems like a bit of a weak link, anybody modded theirs to run a lead screw?

Thanks in advance!

Dan

If I remember correctly the belts are rated from 23–158 degrees F. Wonder if the problem couldn’t be the pulleys slipping? Doesn’t steel contract more than aluminum? Also, the motor shafts are likely warmer than the aluminum pulley — that it’s the Z-axis might lend credence since the Z works harder holding than the other moving axes.

Science demands that you work up some way to heat the space and re-run / test…

Another consideration is that the belts have to be considered a wear item — might be you could loosen it, inspect it, then move it so that the most worn section is right under the static pulley and not engaged in anything.

I did some sketches of a lead screw conversion, based on parts from Robot Digg — notes / B.O.M. here: http://www.shapeoko.com/wiki/index.php/User:Willadams#Acme_screw

I’ve been kind of surprised that no one has done a lead screw conversion — it was one of the first upgrades for the SO1 — of course, it was substantively similar to the M8 threaded rod, so easier to implement.

Well I’ve got it mostly apart right now and the set screw still looks perfectly in line with the flat on the stepper, I will definitely re-check it before re-assembly. Not sure if aluminum or steel contracts more in cold, I suppose I could YouGoogley it?

I do have a blow torch:grin: But seriously, if I could figure out a way to warm my garage I would, I don’t do well in the cold, or the summer heat, I’m pretty miserable if it goes above 90 or below 65, just ask my lonesome motorcycle:rocket: Maybe I should bring the XXL in and set it on my dining room table, my wife shouldn’t mind:scream: Or maybe I’d like to sleep in my warm bed tonight and not the garage, so I think I will just let the SO3 be cold.

This is something I suspect as well, I will give it a closer inspection after a cup of warm coffee. Your suggestion about moving the most worn area to where it rides the static pulley sounds good too, at least until I can source a new belt if that turns out to be the culprit. Speaking of belts, you wouldn’t happen to know of a good source? I bet they have some at C3D, but I don’t see these in their web store, I’m guessing however that these are possibly off the shelf items somewhere?

I’ve been hoping to find something that is fairly plug and play for this, I don’t want to re-invent something that someone who is most likely a bit smarter than myself has already created. While I don’t like the belted Z-axis I’m more of a “make stuff with my machines as a hobby” than “make my machine INTO a hobby” kind of person. I’ve gone mod crazy on a couple 3D printers and in the end I got a little tired of tweaking the machines just so I could produce some actual parts with them. I also wonder if the performance of the standard belted Z-axis couldn’t be improved with some slightly weaker carriage springs? That’s a simple enough mod that I may be able to source at my local ACE hardware, the stock springs have always seemed a little over rated for the weight of the Dewalt.

Thanks for the help Will, I will report back if I find a solution!

Dan

We have a page on Parts and sources for the Shapeoko 2, which is slowly getting up-dated for the SO3:

http://www.shapeoko.com/wiki/index.php/Parts#Z-axis


http://www.sdp-si.com/products/belts/gt2.htm

Note that originally this was specced at 524, but was then changed to 520 — get 520 — even the original machines have sufficient adjustment to make it work.

Do you have a dust shoe? Sometimes with a tighter hole and my dust shoe a bit to low I get the jumping you are describing. I just pull my dust shoe for the cut and continue on. G/L Ray

1 Like

Well I tore the Z-axis apart last night and the results were nothing unfortunately. No missing teeth on the belt, no pulley slippage. The belt had however taken a “set” and in the cold weather it was pretty stiff. I rotated it close to 180 degrees so fresh teeth and on the output shaft pulley. Re-adjusted my V-wheels while I had it apart and got everything running really smooth. Prior to total reassembly I ran the Z down as far as I could and no slipping, at least without a load (this was probably 1" deeper than my deepest cut prior). I finished assembly and it slipped again during the actual run, no joy:( So I changed my DOC to 1/16" in CC (shouldn’t matter because I made several successful cuts prior at 1/8"), and I also removed the brush on my dust shoe (also shouldn’t matter because it worked before). Success!!! So two “theories” I have that I can’t test individually right now: 1) Belts don’t like the cold, cuts need to be less aggressive in the cold, and 2) Some smaller deep pockets don’t like the brush on my dust shoe (although cut prior was same depth albeit a slightly larger pocket), this would be where a set depth dust shoe would be an advantage over one that moves with the Z like mine.

Thanks Will, I’ll get a couple on order as a backup and probably swap out the current belt that came with my XXL just to remove any possibility that;s where my issue is.

Yes, definitely possible, and yes this was a slightly tighter hole compared to the previous ones I ran earlier (see above). I was running a pretty log bit with my long brush, my final solution involved removing the brush. If I can source another brush I’ll try thinning out the bristles to make it more supple and see if that helps. May also look into making a fixed depth dust shoe for when I do features like this.

Thank you guys for all of the help, I’ll revisit this topic if I can duplicate the error with either of the two individual possible issues removed to prove for sure which one was causing it.

Dan

1 Like