Z-depth dropping mid-job

I thought I had solved the issue of my machine randomly plunging too deep into the stock mid-job. I was having issue primarily with the 3D adaptive toolpath (I’m using Fusion 360), but I switched to a 2D adaptive and suddenly bam, no issues. I had no idea why that should make any difference at all, but I figure I’d carry on working and maybe post here about it later when I had some time.

Well, today I ran a 2D adaptive toolpath with the same model that I successfully cut less than 2 weeks ago, and the problem has reappeared.

This is from the 3D toolpath I was having trouble with before, but I’m getting similar results now, only they look even MORE chaotic in terms of where it’s going deeper. I’m at my wits end with this thing. I don’t understand why it keeps doing this, I have no clue how to fix it or even figure out what’s wrong, and support has been no help. I had a call with them, which didn’t provide any insight, and haven’t heard anything back in weeks. They mentioned that I might have to ship the machine back to them - I have no idea how likely this actually is to be necessary, but it’s kind of my worst nightmare.

I’ve lubricated the z-axis, I’ve checked all around for anything that’s loose and it’s all fine, I’ve checked that the endmill is secure and it is, there are no obvious issues. Carbide Motion seems to think that the spindle is in the same Z position, despite the fact that it’s cutting deeper into the material (I’ve been keeping a close eye on the z position value in CM). However, when I stop the job and check the z zero, it’s exactly where it should be.

I really don’t know what to do anymore. I’m trying to get a small business going and the prototyping has already been a long, exhausting process, full of setback after setback, and now I can’t even rely on the machine to do the most basic cuts. I’m exhausted and fed up and I don’t even know if I should contact support AGAIN because this whole thing has just been such a mess and such a headache.

Edited to add the 2D adaptive g-code file, if anyone wants to take a look at that:
Adaptive.nc (3.9 MB)

Check that your retract distance is not too large given stock thickness and tool stick out. If you are bumping into the z axis hard stop during retract moves it will loose steps (typically with a nasty noise) but think it moved OK and then head deeper in the next section. If you don’t hear it with router and dust collection running try a dry run , no stock router and dust collection off.

Nope, no issue there.

If it wasn’t for this comment, I would tell you to eliminate the shoddy connectors they used in the wiring harness. I eliminated the motor connectors for my Z axis motor with soldered connections and heatshrink, and I hadn’t had any Z axis issues since. But you say when you check the Z height, and it
s where it’s supposed to be. That’s puzzling.

The G-code looks fine in NC viewer. Measure endmill stick out when you start and after the problem to see if your collet is slipping (tool getting longer)? You may want just give the collet and spindle bore a good cleaning to be safe. A bit of sawdust can prevent the collect gripping the endmill. I completely remove the collet nut and collet for cleaning at every tool change and blow out the spindle bore before installing the next tool. I had 1 occasion where an up-cut bit tried to find the bottom of my spoil board because I was just loosening the collet nut and swapping endmills with it in place. Over time that allowed enough dust to accumulate that it prevented the collet’s compression when the nut tighten. It was tight but the slots of the collet were full and could not flex normally. After that the cleaning routine was instituted and no more issues.

Interesting. Wouldn’t the endmill slip just from you pulling on it, though? I wrapped a thick rubber band around mine and pulled, to see if it would give at all, and it didn’t budge. I’ll still try giving it a cleaning, sounds like it can’t hurt, but I’m not optimistic that that’s the problem.

Yeah, the whole issue is pretty puzzling. Nothing seems to make sense. I’m starting to think at this point that there’s just something fundamentally wrong with the machine.

I would not expect you to be able to pull it out by hand, The twist of the endmill engaging material can produce much more force “screwing” the bit into the work piece. A couple of thousandths at a time adds up over many minutes of cutting. Measuring stick out with calipers before and after a cut is the best way to be sure. Inspect the collet for wear as well when you clean it. If you have a spare try switching collets.


You could also mark your tool bit at the point where it enters the collet with a sharpie, then snap a pic of the mark with your phone. When you notice a deeper than expected plunge hit the pause button on CM and compare the marks current position with the picture.


I don’t have a machine yet but do have years of experience working on production machines including CNCs. One quick thing to try is to replace the collet to eliminate the collet as a possible issue. This is a relatively low cost thing to do. As mentioned earlier, these machines use stepper motors with no actual position feedback. An axis knows where it is only because it knows a step is equal to a particular measured distance traveled. If you push an axes to hard, ie. plunge into material to fast, the motor will electrically step, possibly without physically moving that step. These mis-steps can accumulate as well. Just something to be aware of.


I came here to say exactly this. Not sure if it was a me pushing too hard with my feeds or if the collet nut wasn’t tight (probably a combo of both) but my endmill slowly walked itself out during a cut I was making. I would say start with this as it is an easy check. Always eliminate easy stuff first.

1 Like

I did exactly this, ran a job, had the z-depth drop about 2mm mid-cut, and…nothing. The endmill hasn’t budged. So, it’s not the collet. I really think it’s an issue with the electronics somewhere.

Please take photos of your Z-axis motor wiring and connectors, including at the controller and send them in to support@carbide3d.com

Aside from the very obvious wires coming out of the motor, I don’t know where/what anything else is. No idea where the “controller” even is. I’m still new to CNCs and this thing doesn’t come with an operator’s manual. I’m in touch with support, though, and I’ve passed along everything I know about the issue so far.


Yes, I’ve seen all of these guides. Nothing here actually tells me where the wires are or anything about the electronics, except sort of the bitzero assembly guide, but from what I can see, it’s written for Shapeoko users. Which makes sense - my bitzero just plugs into the machine, no assembly required. And it doesn’t show how one GETS to the controller. I assume it’s fairly straightforward, if you actually know anything about these machines and their hardware, which I don’t.

I’m going to take the bamboo cover off and take a look around the machine, but I’m once again finding myself annoyed at how un-detailed, unorganized, (and often out-of-date) these guides are. I’m sure if I was having a smooth user experience with the Nomad and not this weird, head-scratching failure, I wouldn’t care so much, but alas…

Is it normal for the electronics to have dust on them like this?

I know my PC gets a fair amount of dust in it over time and runs just fine - I clean it out with compressed air now and again - but I’m trying to cover all the bases. Nothing else jumps out at me as being amiss.

This happened to my HDM a couple weeks ago along with my X axis shifting several thou to the right after tool changes using proven files that were previously cutting flawless on my machine.

I just got help from my brother today to check all my ball screw coupler set screws to see if they were tight and only the X axis needed a little over an 1/8 of a turn. If it shifts in the X now I will have to contact support because I’m not cutting heavy enough to miss steps. If the Z drops again and destroys another modvise, new part, and endmill. I will blow a gasket regroup and then contact support and look into a better connector at the motor side.

I had the same problem and am embarrassed to say it was only a loose screw on the assembly.
The collet is something to consider. The collet should be completely cleaned on a regular basis. I trashed my first one by not paying attention to dust buildup. It is usually the simple things that bite me in the end.

I can’t find anything that’s loose on the assembly, thought I didn’t go around checking individual screws. Does the Nomad 3 even have a screw somewhere that needs to be tight to support the z-axis?

It’s not the collet. I marked the endmill and it’s not slipping at all. It’s not loose or damaged, and it barely had any just at all on it when I took it off to examine it the other day.

I would LOVE to be able to find some stupid thing that I just overlooked, but this has been going on for months and I feel like I’ve checked and double checked everything and there’s just no good explanation anywhere. It has to be something to do with the electronics, I just don’t see how anything else is possible.