Z zero gets set to position above stock when job runs

I have a simple job that carves a panel out of aluminum. In CC I set the stock thickness to 2mm and the Z height at stock top.

When I start CM I set Z zero to the top of the stock, but when I start the job Z zero appears to change to about 2mm above the stock top! Nothing gets carved. This does not make any sense to me.

Is this a bug, a misunderstanding on my part?
Files attached.
IM-2131-VCO-AluminumPanel.c2d (216.3 KB)
IM-2131-VCO-AluminumPanel.nc (179.9 KB)

Your design has the wrong Z Zero:
Capture

1 Like

I’ve tried both top and bottom with the same problem

How are you setting zero?

If you jog down to Z-axis zero is it where you expect it to be?

How are you setting zero?

If you jog down to Z-axis zero is it where you expect it to be?

I’m using a piece of paper between the bit and the surface of the stock. After zeroing the bit goes to where I expect Z zero to be. It’s only after starting the job that zero get altered.

Please post the .c2d file, generated G-code, step-by-step notes on how you are securing your stock and managing all tool changes and a photo showing an attempt at cutting still in place and we will do our best to sort this out w/ you.

If you can’t share the file, send it in to support@carbide3d.com

I don’t know what I did right, but I exported the Gcode again and now it is carving correctly. The only thing I did different was I explicitly change the zero height to top of material (which is the default, I think).

Anyway, thanks for everyone’s help and encouragement.

1 Like