Z Zero Will Not Save

I have had my Shapeoko XXL for over 6 months. For the last couple months I cannot get the z zero to save properly. I have no changes my set-up process from when things were working correctly. I have a bit zero and bit setter, each I have been using since I received my machine. With or without the bit setter my z zero always saves inaccurately. Every time I go to cut, I’m either cutting inches above my workpiece or my bit drives right through my piece. I have ruined many customers pieces and am starting to give up on Carbide 3D. When I stop the cut and go to check my z zero, the bit will drive itself into my waste board. I am worried by z+ could be injured due to this error happening consistently.1 in 5 attempts to cut will save the z correctly, so I know this is not due to human error. I have multiple customers with ruined custom pieces and I cannot use my shapeoko for work anymore. Please do not recommend I update my machine software, as it is redundant. Any assistance will be appreciated as I am frantically looking for a new machine that will not ruin my customers work.

1 Like

I have 40 plus years of experience with fixing machines. When you have a unique problem isolated to a single machine you have to look for something unique in your environment. A few people have zero problems but it is usually something particular to technique or a fault with thier single machine. If every one was experiencing this loss of zero the forum would be lit up and it is not.

Depending on your Z axis take a look there first. Is your belt tight, your v wheels properly tightened. What is your retract height. Any problem is solved by starting with the basics. Do not assume anything. Start at the beginning and go through every thing step by step and do not skip any thing because you assume that cannot be the problem.

Contact support and get a list of trouble shooting steps and follow them. After trouble make several projects on scrap and be successful before moving on to customer projects. You may think this is a waste of time but weigh that against how much time has already lost. The only to fix an elusive problem is methodical step by step troubleshooting until you get a fix

If buying another machine is more effective time and cost benefit, sell the Shapeoko and move on. Most likely it would be more efficient to fix this one but it is your time and money.


You certainly would not be the first person to have a periodic workflow issue with the bitsetter, if you have a search of the forum here there’s quite a few folks who were occasionally performing a step out of order and getting similar results in terms of Z offsets.


Please let us know step-by-step:

  • what you did
  • what you expected
  • what actually happened

for each and every step of how you work with a file which has this problem.

Please provide:

  • .c2d file
  • generated G-Code
  • step-by-step notes on how you are securing your stock and setting zero relative to it
  • step-by-step notes on everything done relating to tool changes

Guy -

I appreciate your assistance. I have the Z+ so it has a lead screw, that is why I am worried about the times it has driven itself into the waste board. There is no belt to slip so I am concerned the motor is taking the beating. I am not very experienced in electrical motors so the troubleshooting process has been difficult.

The difference in z change from when it is set with or without the bit zero, is drastic and different every time I go to cut. This leads me to believe this is a software issue. It seems like the machine has a brain fart when I click run and forgets just my Z zero. Everything other than software or electrical issues, I have no problem overcoming but this one has me stumped. Maybe customer support has some valuable troubleshooting solutions.

I am considering a new machine because of the cost of customer work I have had to replace recently. Unless I can get this machine operating properly soon, I may have no other option. Again, thank you for your help.

If a bitsetter is involved, the most important thing is to never change a bit without using the “Change tool” button in carbide motion.
If you change it without telling the software, generally bad things happen like Z going deeper than your zero etc etc


Will -

What I Did -
I am proficient with Carbide Create and Fusion 360, for this project I was using Illustrator to create an inlay for a customer’s jewelry box lid. I exported my illustrator file as a .svg. Then imported the .svg to Carbide Create. I created my toolpaths and generated the .nc file. Fixtured the jewelry box lid and used the bit zero to get my work offsets. Jogged my spindle to a random area to test the offset using the rapid position. Confirmed all of my offsets were correct and clicked run file. I have attempted this exact same process with the bit setter engaged and disengaged and received the same results below.

What I Expected -
For my work offsets to have saved correctly and my mill to properly execute.

What Actually Happened -
The spindle drove my endmill straight through the customer’s piece and continued into the waste board. It was able to rip the jewelry box lid from the fixture before I was able to hit the emergency stop. (One I made since Carbide 3D did not include a physical one :wink: ). Hence, why I was so upset in my original post. Face Palm, another customer piece down… This is a reoccurring issue and also occurs when generating cam files from Fusion. The machine and rails are clean, all associated software is updated, and my z axis holds consistently moving horizontally, but the work offset for the z axis is randomly generated to a new coordinate every time I click run file.

.c2d file attached -
Pat Jewelry Box.c2d (45.0 KB)

.nc file attached -
Pat Jewelry Box.nc (292.5 KB)

The stock was fixtured to the MDF waste board with T-track and clamps.

I have a bit setter for tool changes, but this does not happen when tool changes occur. Z zero will stay constant through tool changes, when using the bit setter.

Please let me know if you have any trouble shooting tips!

If you change an endmill w/o using the BitZero, then the Z has to be re-zeroed per:

unless you are using depth ring collars or a gauge block or some other technique for ensuring consistent endmill stickout.

If you change an endmill using the BitZero, then it must be done using the interface in Carbide Motion.

Please provide a step-by-step reproducible set of instructions for causing this problem and we will do our best to look into this with you.

the most important change tool event is the one you do just before setting the work piece zero.
If you do that one without using the change tool button… (which will measure the new bit BEFORE you set the zero), your Z zero will be very very off.

(when you turn the machine on, and initialize it, it asks for a bit. that asking counts as using the button)


Will -

I am not having this issue between tool changes. This is an issue I am having any time I start my machine. I have familiarized myself with all of the guides Carbide 3D has to offer prior to receiving my machine and have had no issue until recently.

Let’s forget I have a bit setter. I attempted my same process with it unplugged, and reinitialized my machine. I fixtured my stock and found my work offsets using my bit zero and a 1/4 endmill that was used for the milling operation. After jogging the spindle away, I checked the work offsets using the rapid position function. Once my work offset was confirmed, I started the milling operation and the z offset was regenerated to a new location.

I am NOT running into this issue when performing tool changes. Any operation requiring multiple toolpaths will initially start at the incorrect z offset and all other operations will keep the same incorrect z offset. The z offset is not changing during tool changes, only before starting the first toolpath.

Is this a repeatable issue?
Do you know when it will happen?

1 Like

Please provide repeatable, step-by-step instructions for causing this problem and we will look into it.

The usual cause is excessive retract height — the Z-axis lifts up, loses steps against the top stop, and the machine then plunges too deeply because it isn’t has high up as it believes it is.

Neil and Will -

The issue is it happens at random. I can’t find anything in my process that is different from when the machine was operating flawlessly. If I run the same file 5 times in a row, 1 or 2 of the times I run the machine it will find the correct z offset. The other 3 or 4 times I run the file, it will start the operation at a random z height. My process follows the Carbide suggested process from the Carbide 3D Guide so I’m not sure how to make this a repeatable for another user.

1 Like

Will -

I may have to record a video, because I am following the Carbide 3D guide step-by-step. I do not believe this is a repeatable process.

In that case, please send a working .c2d file, generated G-Code, step-by-step notes on how you secure your stock, and set zero relative to it, and how you manage each tool change, a photo showing a failed attempt at cutting in place, detailed photos of each connector/connection, a verification that all the wiring is in good condition and your estimate on how often the problem occurs and how many successful runs you have had with that file.

I hate to sound like a broken record, and to avoid coping and pasting my previous responses. Please see above for requested files. I will send a video and pictures of my process this afternoon. My workholding methods are also stated above as well as my process for finding my work offsets. I also mentioned my success rate is 20-40% no matter what file I am running. It can be generated by carbide create or fusion 360 and I still receive the same results. I will follow up with a video and images soon. In the mean time please reread our conversation and let me know if you have any specific questions regarding my work holding, offset zeroing, or tool changes that do not have an issue at all.

If your machine is in warranty maybe you could get your controller replaced. If it is out of warranty I bought a new controller for $99.00 about a month ago. My usb connector has always been flakey so I bought a new one. The controller is the brain and would be cheaper than a new machine.

1 Like

That sounds like the only place the issue may lie from what I can tell. I will look into that if Carbide doesn’t have any troubleshooting tips. My machine is under warranty so hopefully they can replace it if we can find a way to determine it is the fault of the controller.

I have found if the distance between my zero and the top of travel is not enough it looses its z zero. The telltale is a slight warble when it retracts.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.