Aspire help - curved chair back


(Mike Whitney) #1

Hey guys - hoping to get some help with carving a double sided chair back.

Here’s what I’ve done (screenshots of Aspire attached).

  1. Created model in Google Sketchup
  2. Created art-board in Aspire (17" x 8" x 2" for the wood blank).
  3. Set job type to ‘double sided’ - assuming this is correct as I’ll need to carve the top curve and reverse curve for the back (no idea how to flip this on the Shapeoko…)
  4. Imported model
  5. In ‘Modelling Tab’, I hit ‘centre model’ under ‘model size’ - I thought this would essentially centre my 3D model into my earlier defined ‘blank’ (or art-board) during file setup.
  6. Hit OK

When the model is rendered, it looks as if the piece has been cut in half (missing the curved portion / underside of the model.

This is where I’m stuck.

  1. Is it normal to clip this off or should it be showing me the completed model?

  2. I want to carve one side (the dish / concave portion) and then flip it to carve the back part (convex portion). I have no idea how to do this / set up tool paths to make this happen.

  3. I got as far as heading to the Toolpaths tab, creating a 3D roughing toolpath with a 1/4" ballnose bit, was going to create a 3D finishing path to smooth out along the X axis, but I’m currently lost with the missing other half of the model and not sure how to best go about toolpath setup.

Any help is greatly appreciated!!




(Stuart) #2

Hi Mike,

what version of aspire are you running? I have version 8 (not version 9 as thought) and it doesn’t support double-sided machining the same way software like Fusion360 does.

If you have the same version, the way around it is to create one model for each side of the chair back. i.e one model for the convex side, one model for the concave side, ensuring that you set your Zero’s appropriately.

I think the newer versions of aspire support double sided machining - if this is what you have I’m not much help with that - maybe vetric forums or youtube would be a good place to look


(ray) #3

version 9 absolutely supports 2 sided machining.


(Stuart) #4

ah my mistake… I have version 8, I knew the version after mine supported two sided machining

Capture


(Mike Whitney) #5

Thanks for responding, guys. Yes, I have version 9 of the software.

I’ve since located a tab along the top pane that toggles the view for the sides being carved. I think I’m on track now.

One question I have though, is that when I do a perimeter cut around the piece (because I want this stock to remain full thickness for location pins), the tabs I added aren’t showing up on the 3D View Tab.

I’ve tried changing the resolution, tab size and so forth, but nothing seems to be working. I’ve attached two screenshots - one showing the 2D view w/ tabs and then the 3D view where the tabs aren’t rendering…

I appreciate your help.
Regards,
Mike


(Tex Lawrence) #6

Do you really want to cut into your location pins? :smiley:


(Stuart) #7

Double check your cut depth. Tabs are always at the bottom of a toolpath and extend upwards by the tab thickness you have set. If you are trying to cut deeper than the material thickness, the tabs may exist below the bottom of the material.

Also double check the tab length and height - too long or too high a tab will not be previewed or cut. Also be sure they are aren’t too small - usually around 12x5mm is sufficient

Also I would be going for less tabs if it were me - 2 on the short edges and 3 on the long edges should be enough

On a side note - I just upgraded to Aspire 9 - looking forward to getting into it!


(Stephen Gullage) #8

Are you running any toolpaths on the other side as well? If you’ve already run the convex portion of the job, where your tabs are may not be 2" thick anymore. Try making the tabs 1.5" tall and see if they show up. That’ll tell you for sure.


(Mike Whitney) #9

Good call :wink: (editing…).
TY.


(Mike Whitney) #10

Hey gents -
I think I sorted it out. The tabs only show when I toggle the selector to preview both top and bottom (or just the bottom of the piece). This makes sense as the tabs would sit below center - I’m assuming that’s why they weren’t showing in top view - see bottom view, here (I’ve also changed the number of tabs. Thanks Stutaylo):

One thing I’m not sure how to do is to leave the perimeter block at full height - in this case, 2". When I select the model to do a rough or finishing pass, I choose ‘model boundary’ from the ‘Machining Limit Boundary’ pane. However, it still machines the stock during the roughing and finishing passes. I thought the perimeter that I set (where the tabs are) would stop the machining outside of that area (the thin boundary around the piece), but it did not. I know I’m missing something simple.

Here is a sequence showing the top cut - roughing pass to smoothing pass.

Thanks in advance for your help.

2" Stock

Perimeter cut - all good. 2" stock remains intact.

Roughing pass removes height from entire piece even beyond perimeter.

Smoothing pass, same thing. How do I get the milling to stop at the perimeter cut? The reason I want the stock ‘border’ to remain is so that when I flip it, there’s a solid foot to sit on.


(Stephen Gullage) #11

If you send me your file (change extension to .zip when you message it to me) I’ll take a look and see what I can see.


(Stephen Gullage) #12

I took a look at the file and I’ll respond here in case anybody else is interested in what I figured out.

Aspire thinks the model edges are right to the edge of your stock, not to the edge of your piece. This is because of the object called “Limit Planes”. Assuming it’s artifacts of the whole import process?

What’s happening is, the 3D passes are covering the whole material instead of just to the edge of your component because there are 3D elements that cover the whole material. Aspire carves ALL 3D elements in the material space, not just the ones you select, which is a pain. Sometimes you want to carve different objects with different toolpaths, especially if they’re far apart, but Aspire just generates a single toothpath for all of the visible ones.

There’s a couple of ways to fix the issue of the extra 3D plane. The simplest is to select, in both the roughing and finishing passes on both side, to only go to the “selected vector”, and select your cutout rectangle. This will only machine up to the line you’re cutting out, leaving your happy little anchoring wood alone. However, what will happen is that the paths will only cut down to the models on both sides but because they’re separate objects, leaving an onion skin left over, like so:

Alternatively, if you choose the object “Curved Meditation Seat” and use the “create vector boundary around selected components” (Middle icon, third row on Modeling tab, blue line around icon) it will create a line surrounding the chair back. Then you can select the “limit planes” object and this boundary line, then use the “split the selected component using a vector” (third icon, third row) and split the object into A and B. One will be the excess stuff to the edge of your material, and the other the bit in the middle of the chair back. Delete the excess and your objects will now be exactly what you need it to be, and you will only carve the seat back. The drawback is that you leave uncarved bits around the curve, like so:


Instead of using your cutout rectangle to do your cutout, choose the boundary line we created above, and you get:

Added bonus of more material to attach to your wasteboard and doesn’t cut in to your alignment holes (not shown)

Copy the boundary line to the other side, then cut the limit planes object on the bottom with it. Delete the excess. Regenerate your 3D toolpaths as they are, and change your cutout to the boundary line (you’ll have to generate new tab positions.


I also figured out why you don’t have tabs. It’s because you have a cutout toolpath on both sides. The bottom does a cutout first, putting tabs at the bottom of the cutout. When you flip it over, the tabs are now at the top surface, and the cutout toolpath just cuts through them.

You only need one cutout though, so maybe just one the second side you plan to do (top?). If, however, you tell the two cutout toolpaths on each side to just cut 1" into the material, then you get tabs half way into the material.

TBH, cutting into 2" material is going to be tough anyway, unless you have a really long endmill (2"+ flutes), and you’re going to have to cut really slow in order to not get a lot of deflection. Might be better to do cutouts from both sides anyway. Do tabs in both, they don’t have to match each other. Tabs on the short sides from the back and tabs on the long side from the front may not even touch the material due to the deep curves.

Some added considerations that occurred to me as I was looking at your file:

For better finish, run a rough cutout toolpath, 0.0625" offset from your boundary line, then a finishing toolpath with no offset. This will limit deflection for a 1" deep cut. If you’re doing 2" deep cuts, you might want to add additional toolpaths to sneak up on the line (one each at offsets of 0.125" , 0.0625", 0.03125" , and 0")

Your alignment holes will be problematic. Cutting 2" through the material and then into the wasteboard enough to put your dowels into will be very difficult unless you have a drill bit in your router. You’re going to need a 1/2" drill bit (your design has 1/2" alignment holes) with a 1/4" shank that’s both long enough to cut 2 1/4" - 2 1/2" deep plus short enough to be able to put it in the router and clear the 2" of material. You’ll need at least 4 1/2" of clearance from the bottom of your router to the wasteboard. If this is an issue, then a solution is to cut a 1" deep pilot hole in your material with a regular endmill, then use a drill with a 1/2" drill bit to finish the job before your remove it from the wasteboard and flip it over.

On the toolpaths tab (right side of the screen) there’s a material setup button. You may want to ensure that the “Model Position in Material” slider is down a little to leave a couple of hundreds gap above material. You can set it up to 1/8" to put it in the middle of your material. This will ensure that any inconsistencies in the material surface will not affect the high points of your model.

Hope this helps, let me know if you need any help or want me to review your design again.


(Mike Whitney) #13

Hi again, Steve -
OK - I think I resolved my first issue above and successfully created a vector around the object.
Please seen rendering:

When I toggle the view ‘Toggle Top/Bottom Side’ and then go to the 2D view so that I can do the same operation for the underside (and add tabs etc), my drawing is gone:

Any idea why this may be?

I’ve attached the file (test1) of what I’ve done so far and hoping I can continue to make progress working through your instructions. My thinking is that if I bore the locator holes about an inch down, when I carve the first side, I can finish these down to my wasteboard with a hand-drill using the milled holes as a bit guide.

TEST1.crv3d.zip (610.2 KB)

Thank you again,
Mike


(Stephen Gullage) #14

On the back, you can’t see anything because material is covered by your object plane. Uncheck the box next to limit planes and it’ll disappear, and you’ll see the rest of your components and material limits


(Mike Whitney) #15

Ah - got it. Rookie mistakes ;). Thank you. Hopefully I can sort this out from this point.
Have a good one!
Mike