Carbide Motion 2 Beta


(Rob Grzesek) #1

I just posted a beta of Carbide Motion 2 to:

http://carbide3d.com/downloads

This should fix:

  • Invalid Parameters Warning
  • Support European machines with interlock firmware
  • Update OpenGL support for Dell XPS machines
  • Add support for G94, G91.1, G40, G49, and G43 (ignored) for Fusion 360 support
  • Problems with filenames containing special characters like “#”
  • You can no longer jog the machine until you hit a limit switch

Most importantly, this build moves all offset management into Carbide Motion and out of the GRBL processor in the Nomad. We’ve tested it a lot and it seems to work but who knows what bugs are lurkin.

Still to fix:
Jogging is still not ideal, so we’ve got a few more fixes there. There were enough people with the “Invalid Parameter” warning that we had to push this out before wrapping up jogging.

Let us know how it works for you.

-Rob


Jogging feature in main page video?
(Leith) #2

Thanks guys this is awesome! :stuck_out_tongue_closed_eyes:


#3

I like the Fast and Slow options. And the invalid parameters error has disappeared.

Please bring back the 10mm option.

Unfortunately, I’m having some trouble with it. Most of the time, after homing, this error is produced…

And, it takes the software about three seconds to respond to a keystroke which makes it impossible to use.


#4

Yep I am getting the same: GRBL Error: Not idle
This comes if you load the file first and then zero, If you zero first it works.


(Samuel) #5

Just got my first chance to try it tonight, and ran into a weird issue.

It went through the roughing pass perfectly. I switched tools for the finishing passes, it measured the tool length, and then proceeded to do the finishing pass in the air a centimeter or two above the top of the stock.

I’ll try again (either later tonight or tomorrow morning) with the older version to see if it’s some bug in my toolpath, or if it’s something in Carbide Motion.


(Samuel) #6

Running the same .nc file with Carbide Motion 1.0.266 worked. So it seems there is a post-tool-change calibration bug in 2.0.293.


(Leith) #7

oooo that’s a bit of a major…


(Samuel) #8

OK, there are definite offset issues with this beta. I just tried to run a single-tool carve, and after going through the usual zeroing and set up, when it started to do the cutting, it plunged straight down 6mm into the stock (hard oak) and snapped off my 1/16th inch ball mill.

FWIW, I’m running the Mac OS build under OS X 10.9.5


(Leith) #9

Hi sjg

Thanks for this information. I wounder if the bug is also there in the windows version…

Bit scared to run anything on the beta now for fear of crashing my machine.


(Mike Hellers) #10

I had a support ticket open for the GRBL error since a couple of days (I have an EU machine, so need to use the Beta version). And after a couple of updates to the beta version there is good news: it looks like the bug has been fixed in the latest Beta release (2.0.300) which is the one you get now if you download the beta version.

I have run a number of small tests so far, and it is looking good. Haven’t seen the GRBL error at all anymore, where as before I saw it each time, unless I homed the machine before loading a file. (I am using OSX 10.9.5)

Mike
London/UK


(Samuel) #11

I didn’t know there was a bug ticketing system. I should post my bug there! Is it somewhere on the GRZ Software site?

Thanks,
Samuel


#12

Sadly I’m still getting the Invalid Parameters errors.
Also hanging up with a grbl error after aborting a job (e-stop)


(Mike Hellers) #13

Samuel,

No, GRZ are the makers of Meshcam, but the bugs described here are linked to Carbide Motion, which is developed by the Carbide team themselves, so support tickets can be raised through support@carbide3d.com.

Mike
London/UK


(D S) #14

I can also confirm z-offset issues. Went back to Carbide Motion 1.0. From my notes the other day:

"If you set the coordinates with one tool, and then change tools before starting your part, there does not appear to be any tool height compensation.

Noticed several times - With no tool change even, first cut will be far too deep - go back and check Z offset, off by ~1 mm. Went back to CarbideMotion 1.0 - > Problem disappeared."


(Rob Grzesek) #15

@dr_g - Can you do the following:

  1. Connect to nomad
  2. Press L to open a log window
  3. Press M to open MDI window
  4. Enter $$ and click Send
  5. Send me the contents of the log window.

I’ll be sure to remove the invalid parameters warning for you.

@dinos, @sjg - I’ll poke around at the tool compensation tomorrow now that (I think) the GRBL Error problem has been fixed.


#16

Test Waiting…
<Idle,MPos:-220.005,-10.001,-5.000,WPos:-220.005,-10.001,-5.000,Buf:0,RX:0,Ln:0,F:0.>
gc_not_motion
___________$$ ___________
$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=255 (status report mask:11111111)
$11=0.020 (junction deviation, mm)
$12=0.010 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=1 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=100.000 (homing feed, mm/min)
$25=1000.000 (homing seek, mm/min)
$26=25 (homing debounce, msec)
$27=5.000 (homing pull-off, mm)
$100=88.889 (x, step/mm)
$101=88.889 (y, step/mm)
$102=200.000 (z, step/mm)
$110=2600.000 (x max rate, mm/min)
$111=2600.000 (y max rate, mm/min)
$112=1270.000 (z max rate, mm/min)
$120=270.000 (x accel, mm/sec^2)
$121=270.000 (y accel, mm/sec^2)
$122=270.000 (z accel, mm/sec^2)
$130=250.000 (x max travel, mm)
$131=250.000 (y max travel, mm)
$132=100.000 (z max travel, mm)
ok
gc_dwell
___________G4P0.5000 ___________
<Idle,MPos:-220.005,-10.001,-5.000,WPos:-220.005,-10.001,-5.000,Buf:0,RX:0,Ln:0,F:0.>
ok
gc_get_offsets
___________$# ___________
<Idle,MPos:-220.005,-10.001,-5.000,WPos:-220.005,-10.001,-5.000,Buf:0,RX:0,Ln:0,F:0.>
[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:-220.000,-10.000,-5.000]
[G92:0.000,0.000,0.000]
[TLO:0.000]
[PRB:-220.005,-10.001,-77.070:1]
ok
gc_parser_state
___________$G ___________
[G0 G54 G17 G21 G90 G94 M0 M5 M9 T0 F0. S0.]
ok
<Idle,MPos:-220.005,-10.001,-5.000,WPos:-220.005,-10.001,-5.000,Buf:0,RX:0,Ln:0,F:0.>


(Rob Grzesek) #17

Just uploaded new CM V2 Beta. It should fix the bad Z offset on a tool change.

If feedback is good I’ll tackle some of the Fusion 360 compatibility todo’s on Monday.

-Rob


(Jonathan K) #18

Rock-on! Thanks I’ll give it a try and see if I can get through a multi-tool job this evening :slight_smile:


(D S) #19

Rob - Is Fusion 360 usable yet, or should I wait for your updates before trying?


#20

robgrz

I read this board every day and am learning a lot. I love the projects that people share, and especially when they outline mistakes made and things learned. One of the greatest things is seeing how responsive you are to addressing issues and helping people out. This makes me feel I purchased the right product.