Carbide Motion - Not finishing homing cycle

(Stephen Kidwell) #1

I start my machine, or it finishes a job at the far southwest corner. When it goes to home the machine, it stops short and the jog section returns to having an initialize machine button. Here are my settings:

Not the biggest deal, I hit the button and it continues to home back to the far northeast corner. Just curious if anyone has had this happen on the XXL and what a solution is.

(William Adams) #2


$25=1000.000 (homing seek, mm/min --- on larger machines, consider increasing to 1500)

so please try setting:


(barthelemy bach) #3

I had this before I upgrade motion carbide.

(Stephen Kidwell) #4

I am still having this issue after changing the setting to 1500

(William Adams) #5

Please post your Grbl settings also your Carbide Motion preferences.

(Rob Grzesek) #6

We’re uploading (slowly) CM 413 which has an update to the settings to fix this. I don’t recall the setting, but it’s the X and Y table size in GRBL that are used to derive the maximum homing time. Make them something like 850 and it’ll work fine. (Or wait for the latest build to go up)


(Stephen Kidwell) #7

Not sure what the Grbl settings are but in Carbide Motion it says 850 x 830 which seems to be default for the XXL in the drop down menu. Not sure if thats what your looking for tho.

(Rob Grzesek) #8

Nope- those are internal to CM, not GRBL. Grab CM413 and download the settings to the machine again and it should be updated.

(Stephen Kidwell) #9

Ok, will do. I will try tomorrow thanks mate! I really love this forum! Fastest one I have ever used.