CM gives GRBL Error Message after going from Laser back to CM


(Richard Hensley) #1

After I use my J-Tech laser with Lightburn I switch back to CM and get this message immediately after connecting to my Shapeoko 3:
GRBL error: unsupported or invalid g-code command found in block

Is there a sequence I need to follow in order to switch between the two? Need help…

Thanks

Ric


(Richard Cournoyer) #2

I think we need more information here to help you.

  1. What changes did you do then when you switched to the Laser?

  2. Can you attach your gcode that is giving you this error?


(Richard Hensley) #3

I followed the instructions from J-Tech to the Tee. The only changes were size of working area. I changed to 812mmx812mm and adding 1 to line 32. I used macros to go between laser settings and Router settings.

The error message is coming up before I load the G-code. When I turn on the Shapeoko and open Carbide Motion the error pops up before I home the machine. I’ve tried everything shy of reloading the GRBL and starting over.


(mikep) #4

Ok, then it’s something in the macro you use to go to router settings. Attach it here and we might be able to help. It may be there is a newline missing from the end or something, and when carbide motion starts it sends some commands and one might not make sense because it’s getting stuck onto the end of the macro.


(Richard Hensley) #5

G10 L2 P1 X-812 Y-812 Laser Settings

G10 L2 P1 X0 Y0 Router Settings

These are the only 2.


(mikep) #6

I suspect there’s a carriage return/newline missing when the router one is sent. After you send it, can you send a couple carriage returns to grbl? Not clear what software you’re using (not carbide motion, it doesn’t do macros…)


(Richard Hensley) #7

I’m using Lightburn for the laser.


(Richard Hensley) #8

I tried sending a couple of carriage return after sending the macro. No change. I’m considering just reflashing the GRBL for the Shapeoko 3. I’ll worry about the laser later. I really need my CNC back. Thoughts?


(Neil Ferreri) #9

Can you post your GRBL settings? Send $$ and paste the output here.


(Richard Hensley) #10

From Carbide Motion I take it.


(Neil Ferreri) #11

Doesn’t matter…the settings are stored on the controller. Whatever is easiest. In CM, go to the MDI and send $$ (I think…I haven’t used CM in years)
Did you change $32 back to 0?


(Richard Hensley) #12

$132=80.000
(955): <- $131=850.000
(954): <- $130=845.000
(953): <- $122=400.000
(952): <- $121=400.000
(951): <- $120=400.000
(950): <- $112=5000.000
(949): <- $111=5000.000
(948): <- $110=5000.000
(947): <- $102=40.000
(946): <- $101=40.000
(945): <- $100=40.000
(944): <- $32=0
(943): <- $31=0
(942): <- $30=1000
(941): <- $27=5.000
(940): <- $26=25
(939): <- $25=2000.000
(938): <- $24=100.000
(937): <- $23=0
(936): <- $22=1
(935): <- $21=0
(934): <- $20=0
(933): <- $13=0
(932): <- $12=0.010
(931): <- $11=0.020
(930): <- $10=255
(929): <- $6=0
(928): <- $5=0
(927): <- $4=0
(926): <- $3=6
(925): <- $2=0
(924): <- $1=255
(923): <- $0=10
(922): -> $$


(Neil Ferreri) #13

Should be $10=1
Did you change that?


(Richard Hensley) #14

That was one of the settings for the laser I believe. I’ll change it back…Would that cause this error?


(Richard Hensley) #15

ok. I changed it to $10=1


(Neil Ferreri) #16

I don’t know, but I don’t know why that would be set unless Lightburn does something behind the scenes with that.

When do you see the error?


(Richard Hensley) #17

I see the error after I connect to cutter. I just tried again and I can’t jog anymore…How do I go back? Can I reinstall the GRBL and go back to defaults for my Shapeoko 3 XXL?


(Neil Ferreri) #18

Do you have LightBurn open too? I’d try restarting the computer before you reflash grbl, but I think you could reflash grbl without issue (if you feel comfortable doing that).


(Richard Hensley) #19

no its closed.

I haven’t had them opened together.


(Neil Ferreri) #20

I’d try restarting the computer before you reflash grbl, but I think you could reflash grbl without issue (if you feel comfortable doing that).