Controller board doesn't show up on USB


(Josh Hartung) #1

Help! The folks at Carbide are unresponsive and so is the machine. I bought a SO3 and received it with a little IOU note that says “we’re going to send your controller board next week”, which would have been nice to know at ordering time. After receiving the board today, it still doesn’t work. All signs point to a bad board, but I’m hoping someone on the community can point me to a work around or some more in-depth troubleshooting.

I get a GRBL error in Carbide Motion (V4):

I believe this is due to the USB not registering in the device manager. I would post a pic but apparently new users can only post one pic so you will have to believe me. About this Mac > System Report > USB shows only my wireless mouse and the bluetooth port.

Here is what I’ve tried:

  1. Careful following of ordering per http://docs.carbide3d.com/software-faq/can-t-connect-to-machine-or-jog/
  2. All troubleshooting steps recommended including restart, reset PRAM, reset SMC
  3. Reinstall CM4 AND rollback to CM3
  4. Known good USB cable
  5. Pushing the reset button on the controller
  6. Alternate USB ports (known good ports that work fine with other devices including Arduino’s)

When I power on, the blue power light is lit and stepper controllers start and hold position. There are no lights at any time on TX or RX, including when I plug/unplug the USB cable. I am doing this all with the spindle off, of course.

Machine is an Intel i5 Macbook Pro, OSX 10.13. Shapeoko is brand new and has never run.


(Josh Hartung) #2

My suspicion is that there is a stepdown converter for the Arduino converting the 24V in to MC voltage (5V?) and it’s not working. Is there a way to power the Arduino over USB instead to test this?


(William Adams) #3

I had escalated your ticket, but the person it was assigned to is out of the office. I’ve responded (such as it is there) and we’ll get this worked out as quickly as we can.

It’s my understanding that there’s a circuit which governs whether or no power is provided by the power supply, but I believe the machines are hard-wired to only accept power from the PS — it might be you’d find something helpful in the documentation for the Stepoko board: https://github.com/sparkfun/SparkFun_Stepoko

Perhaps you could try reloading the bootloader and then reflashing with http://carbide3d.com/carbideupdater ?


(William Adams) #4

One other thing to try — install Universal G-Code Sender and try it, then try CM again — it may be that CM isn’t properly getting access to dialout, but UGS can manage to do so.


(Josh Hartung) #5

I’ll try UGS when I get back to the machine, but it seems unlikely that it’s an application-level fix. OSX is not seeing the control board, which says to me that it’s either a driver issue on my computer, cable/interface problem, or it’s in the control board itself. Since the TX/RX lights are totally non-responsive I tend to believe the Arduino isn’t even trying to communicate. Carbide Updater exhibits the same behavior - it doesn’t see the board at all.

Perhaps it wasn’t flashed correctly and isn’t booting at all? I know they did a quick turn on these boards at the IL facility since there was a big backlog so wouldn’t be surprised if something got missed.


(John Nicolosi) #6

Take the cover off the controller and wiggle the serial port where you plug it in, the receiver for the wire may be loose and not connecting. Usb signal to the board… Just a thought.


(Josh Hartung) #7

@WillAdams confirmed that power is hardwired in, at least on the Stepoko. https://cdn.sparkfun.com/datasheets/Tools/SparkFun_Stepoko_v10.pdf

@Isolocin no joy there. I did a bunch o’ wigglin’ when nothing else was working.


(Jorge Sanchez) #8

Do the on board LEDs light up on the board when you turn power on?


(Josh Hartung) #9

@Jorge LEDs are active as follows:
PWR: solid on blue when power supply is on (and switch on).
X, Y, Z: limit switches, solid on blue when limit switch is depressed, otherwise off
TX, RX: no light at any time (startup, running, plug in, plug out, shutdown)

Only weird thing I did was when I started up the machine, the X limit switch was depressed because I had the carriage over to get the cable lengths right.


(Idan) #10

This happened to me three times, each time for different reasons: the first was due to a fried stepper driver, check that everything looks okay there (it’s easy to miss, look carefully). Second was after a replacement board was sent, it wasn’t flashed correctly (this seems less likely if the controller was previously working). Third time was a bad power adapter, swapped it for a new one.


(Josh Hartung) #11

@idank since it seems to initialize and hold position on all axes I’m thinking stepper drivers and power is okay, but bad flash is interesting. The contoller has never worked. How did you reflash? Carbide Updater needs to see the devices port.


(Griff Carpenter) #12

Check Will Adams post, about 8 back from here :sunglasses:


(Josh Hartung) #13

@griff, I’ll reiterate my issue with (http://docs.carbide3d.com/support/carbideupdater/) - Updater doesn’t see the device port, because the system isn’t enumerating it. My guess is it needs a JTAG or something more in depth.

At this point I believe I’ve found and tried every available public resource on this problem, so hopefully Support will get back to me with steps they would rather not see on the internet.


(Idan) #14

In my case it didn’t show up in /dev either, figured the board is faulty and asked for a replacement. Hopefully you get one soon as well.


(Josh Hartung) #15

Figured, they’ve got another one on it’s way now - graciously without troubleshooting it with me. Thanks @WillAdams!


(Josh Hartung) #16

And success! C3D generously overnighted a controller board and I’m back up and running. Apparently they were off at a company function on Friday so it was my bad luck. Sending the old one back to them for forensics.

Thanks to everyone who chimed in on this thread and good luck!


(Marlon Miller) #17

Awesome news. Seem I having the same issue as you. Just my was on a windows machine. C3D is sending me a new controller. Hoping that works.


(Joe Carroll ) #18

I am now having the exact same issue. Will is trying to help me out with debugging the issue. So far no luck. I also think this board is bad.


(system) #19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.