"Door Open" (I have no door!)


(KSLE Pilot) #1

I am trying to run an urgent job. I have all of the g-code ready to go. Loaded up CM 4.0.409 and grbl1.1. Opened the g-code file and went to start jogging the unit.
Here is what I get. I have an XL and I cannot find which “door” it is talking about. Can somebody help?


(Jim Amos) #2

There’s a new v4 release??
Sounds like something Nomad related?


(KSLE Pilot) #3

I don’t have a Nomad. How did it change from an XL to a Nomad?!?


(Jim Amos) #4

Not having upgraded to v4 (yet), there may be some setting needing initialization?


(KSLE Pilot) #5

I would have thought the same had I not run some jobs through already. I am perplexed…


(Jim Amos) #6

You ran jobs already with CM4.0.409 and GRBL v1.1 already, and this is popping up just now? That’s not how I read your initial description…


(William Adams) #7

The door interlock is a feature which is in place for the Nomads which are sold in Europe (we may also offer this as an option for schools here in the States).

I believe it’s supposed to also be supported by a special firmware — suspect it’s a software glitch in CM where a variable or setting got toggled somehow.

Please check your Grbl settings and CM preferences and send them in to beta@carbide3d.com and they should be able to sort you out — might want to go ahead and go back to CM3 and Grbl 0.9: GRBL 1.1 and Carbide Motion 4


(KSLE Pilot) #8

Yes. Sorry that I didn’t make that clear. Been running GRBL1.1 and CM 4.0.409 and have run jobs with that configuration. Other than it homing to top left, it ran until just now.


(KSLE Pilot) #9

@WillAdams ok, I’ll give that a try.


(KSLE Pilot) #10

@WillAdams I tried closing and reopening CM again and no joy. It won’t let me go to preferences. I tried going directly to preferences (since once I got into the “Door Open” hades, it wouldn’t allow me to anything). I chose the XL…error…error…error.



3


(William Adams) #11

Darn. Please let the folks at beta@carbide3d.com know and hopefully they can work up a solution.


(KSLE Pilot) #12

@WillAdams thanks for all of your help, but I have run out of time and I need to leave tomorrow morning to spread the cremains. I can use some rocks to make a mound. I’ll deal with it when I get back.


(Luke) #13

I’m a bit late to the party, but I can trigger a door error with my emergency/kill switch on my S3. Is yours working ok?


(KSLE Pilot) #14

Mystery solved! Curiously, everything on my computer began to freeze or go batstuff crazy. I checked my “power button” and Microsoft was the culprit. They dumped a humongous update on my computer and after a reboot and 30 minutes of “updating do not turn off your computer”, I now have a working computer and CM seems to be normal again. Weird that it affected CM that way, but if it happens again, I’ll know who to hurl expletives at. Thank-you everyone for your suggestions.


(Luke) #15

windows! once I had an update that wouldn’t wait to re-start. It decided to do it mid job. FML


(Phil Thien) #16

Figures Windows would cause a problem with doors.


(JJ) #17

Blockquote

cgalleryPhil Thien5d
Figures Windows would cause a problem with doors.

Blockquote

The best thing to do with Windows is keep them (sic) closed


(Chad Howell) #18

Exactly why I hate windows and their update pushes. I had one decide to go mid job as well and I was around 4 hours into a 6 hour carve