Fusion 360 and GRBL errors


(Patricio Suarez) #1

I use Fusion 360 for CAD and CAM. I have upgraded to GRBL 1.1 and latest version of CM4. I keep getting GRBL errors while milling. I can’t make sense of it. I have been sending the error codes I get to the Beta team but was wondering if anyone out there using Fusion 360 was experiencing the same thing. Anyone?. Today I keep getting a lot of G2 errors.

Any suggestions?

Just realized that I had posted before about the same problem and that it could be a G19 issue. Beta team has been informed. Anyone is going through the same?


(mikep) #2

Which post are you using? There are several GRBL posts for Fusion360. There’s some discussion over here:


(Patricio Suarez) #3

@mikep I think I’m using the latest version of post for Carbide 3D. It states that it was updated 44 days ago.


(William Adams) #4

Things to try:

  • use metric
  • test w/ some other app
  • turn off ramping in

(Patricio Suarez) #5

-using metric
-another app?. Like UGCS?.
-have tried with ramping off and on

Thank you always for all your help


(William Adams) #6

Yes, try Universal G-code Sender.


(Patricio Suarez) #7

Never have used UGCS to run a job. I’m guessing you use Generic GRBL post from Fusion 360, right?.


(William Adams) #8

For a real test, same as w/ CM.


(Patricio Suarez) #9

I continued trying different strategies in Fusion 360 to see if I could figure out what was going on. Not too scientific but this is what I came up with. Studying the paths, I discovered that the GRBL errors came while the program was moving the head from one place to another. I looked closely at the path and saw a weird little curve.

This was related, I think, to the stay down distance in the linking tab. This were my settings when I was getting the error.

I changed them to this (trial and error):

and I got this:

No more GRBL errors. Don’t really know if this means something to someone. Just posting my findings in hopes of making things better for everyone. Will send this to the Beta team also.


Facing Pass SO3 and Fusion 360 -- bit not making contact with stock
Fusion 360 for the Nomad