Grbl1.1 jog issue & confusion aplenty with unexpected movement!


(Tom) #1

Using Shapeoko 3XXL (with homing switches), grbl 1.1 & UGS Universal Gcode Platform 2.0 [nightly] / Jun 15, 2018

Here are is the grbl configuration

$$
$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 6 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 255 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.010 (Arc tolerance, millimeters)
$13 = 0 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 0 (Homing direction invert, mask)
$24 = 100.000 (Homing locate feed rate, mm/min)
$25 = 2000.000 (Homing search seek rate, mm/min)
$26 = 25 (Homing switch debounce delay, milliseconds)
$27 = 5.000 (Homing switch pull-off distance, millimeters)
$30 = 1000 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 0 (Laser-mode enable, boolean)
$100 = 39.950 (X-axis travel resolution, step/mm)
$101 = 40.000 (Y-axis travel resolution, step/mm)
$102 = 40.000 (Z-axis travel resolution, step/mm)
$110 = 5000.000 (X-axis maximum rate, mm/min)
$111 = 5000.000 (Y-axis maximum rate, mm/min)
$112 = 5000.000 (Z-axis maximum rate, mm/min)
$120 = 400.000 (X-axis acceleration, mm/sec^2)
$121 = 400.000 (Y-axis acceleration, mm/sec^2)
$122 = 400.000 (Z-axis acceleration, mm/sec^2)
$130 = 825.000 (X-axis maximum travel, millimeters)
$131 = 825.000 (Y-axis maximum travel, millimeters)
$132 = 90.000 (Z-axis maximum travel, millimeters)

I use a macro in UGS to set a tool change position
$J=G53 z0.0 f1000;$J=G53 Y-700 f5000; $J=G53 x-100.0 f5000

On startup and after I use my Triquetra to set zero, the macro works just fine. After I run any NC code (Fusion 360), running the macro makes the machine move to the wrong point and causes crashes. I am pretty sure that this is caused by a coordinate system offset, but I can’t figure out what to change to get this to work. Any ideas???

Thanks,
Tom


(Neil Ferreri) #2

@Tlytle999
What post processor are you using in Fusion?
My guess is that you’re ending in incremental mode (G91) where your macro is assuming absolute (G90). Someone else just had this issue. I’m curious as to where, if this is the issue, the G91 is generated.


(system) #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.