Limit switches don't home correctly when gantry close to home


(Michael Hujsak) #1

I’ve put limit switches on my s03 with some homemade brackets. I’ll probably make real mounts out of aluminum sometime (anyone have a 3d model for those?)

Anyway, my cobbled together brackets reduce the table area some. I think I’ve set the area correctly when I try to go to edges the machine stops where it’s supposed to. It homes correctly so long as the gantry is 6-8" away from home in the back corner. If I stop the machine closer than that, then cycle power and home, it keeps going even when the limits are hit.

Any idea what’s going on?


(William Adams) #2

Please review the configuration per: http://docs.carbide3d.com/shapeoko-faq/shapeoko-enable-homing/

If nothing there helps, please post your Grbl settings and Carbide Motion preferences and the specifics of your electronics (NC or NO switches? &c.)