SO3: Compiling latest Grbl [SOLVED]


(Tim Foreman) #1

I want to install the latest version of Grbl on my S3 controller. I downloaded the source from GitHub, modified the config.h file and compiled the hex with the Arduino compiler.

I used my USBTiny programmer to flash it to the controller and it appeared to load fine.

But when I connect with bCNC it doesn’t seem to be responding correctly. It makes the connection, but Grbl doesn’t appear to be responding.

I’ll be doing some more troubleshooting this evening but I was wondering if there was a list of any special S3 specific settings in config.h that I might have missed.

Thanks!


(Tim Foreman) #2

Digging in the Grbl source I see one thing that I missed. In config.h I didn’t change

#define DEFAULTS_GENERIC

to

#define DEFAULTS_SHAPEOKO_3

But as far as I can tell that shouldn’t affect the communication. I’ll re-compile and re-upload this evening and then do some testing.


(Tim Foreman) #3

Okay, well, I solved my own problem.

I used my USBTiny to flash a bootloader onto the controller then I used the Arduino IDE to compile and upload the code through the USB port.

That appears to have worked quite well.

Of course I didn’t write down all my Grbl settings before I started so now I have to re-calibrate my steps/mm settings. Oh well, at least I have a process for that.


(Kevin Carrico) #4

if you don’t mind… and since i have a sparkfun SO3… do you know what the default grbl settings for the SO3 are?

EDIT: never mind, i shoulda searched first — my apologies.

http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings


(Charles Peterson) #5

Anyone know where I can get a copy of that settings file? This link is broken.
http://docs.carbide3d.com/article/38-shapeoko-3-default-grbl-settings

maybe it is this one?